aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.39/202-spi_vsc7385_driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-06-29 08:57:32 +0000
commitf15a427a56e713cb637aeb84349ba3fe02cfe9e6 (patch)
tree0456ec1a1feb352bd0481fba9936533f72be8c4d /target/linux/ar71xx/patches-2.6.39/202-spi_vsc7385_driver.patch
parent40dfb136e7b97de923312603916abbab42c49757 (diff)
downloadmaster-187ad058-f15a427a56e713cb637aeb84349ba3fe02cfe9e6.tar.gz
master-187ad058-f15a427a56e713cb637aeb84349ba3fe02cfe9e6.tar.bz2
master-187ad058-f15a427a56e713cb637aeb84349ba3fe02cfe9e6.zip
ar71xx: add 2.6.39 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.39/202-spi_vsc7385_driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.39/202-spi_vsc7385_driver.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.39/202-spi_vsc7385_driver.patch b/target/linux/ar71xx/patches-2.6.39/202-spi_vsc7385_driver.patch
new file mode 100644
index 0000000000..f6d75ed963
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.39/202-spi_vsc7385_driver.patch
@@ -0,0 +1,24 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -494,6 +494,11 @@ config SPI_RB4XX_CPLD
+ SPI driver for the Xilinx CPLD chip present on the
+ MikroTik RB4xx boards.
+
++config SPI_VSC7385
++ tristate "Vitesse VSC7385 ethernet switch driver"
++ help
++ SPI driver for the Vitesse VSC7385 ethernet switch.
++
+ #
+ # Add new SPI protocol masters in alphabetical order above this line
+ #
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -68,6 +68,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
+ # SPI protocol drivers (device/link on bus)
+ obj-$(CONFIG_SPI_RB4XX_CPLD) += spi_rb4xx_cpld.o
+ obj-$(CONFIG_SPI_SPIDEV) += spidev.o
++obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
+ obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
+ # ... add above this line ...
+