aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch
diff options
context:
space:
mode:
authorMatteo Croce <matteo@openwrt.org>2010-02-28 16:33:15 +0000
committerMatteo Croce <matteo@openwrt.org>2010-02-28 16:33:15 +0000
commit9b4562192780ff4156a41247be8c00f7e9ba447e (patch)
treeb1fce4764cf4bc0677171983ad42622ea71a4037 /target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch
parentd906c0fa8bbdad2027e25e4545ba3de0428d014c (diff)
downloadmaster-187ad058-9b4562192780ff4156a41247be8c00f7e9ba447e.tar.gz
master-187ad058-9b4562192780ff4156a41247be8c00f7e9ba447e.tar.bz2
master-187ad058-9b4562192780ff4156a41247be8c00f7e9ba447e.zip
ar71xx: 2.6.33 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19908 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch b/target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch
new file mode 100644
index 0000000000..1192d99ee0
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.33/206-nxp-74hc153-gpio-chip-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -230,4 +230,12 @@ config GPIO_UCB1400
+ To compile this driver as a module, choose M here: the
+ module will be called ucb1400_gpio.
+
++comment "Other GPIO expanders"
++
++config GPIO_NXP_74HC153
++ tristate "NXP 74HC153 Dual 4-input multiplexer"
++ help
++ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
++ provides a GPIO interface supporting inputs.
++
+ endif
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -10,6 +10,7 @@ obj-$(CONFIG_GPIO_MAX7301) += max7301.o
+ obj-$(CONFIG_GPIO_MAX732X) += max732x.o
+ obj-$(CONFIG_GPIO_MC33880) += mc33880.o
+ obj-$(CONFIG_GPIO_MCP23S08) += mcp23s08.o
++obj-$(CONFIG_GPIO_NXP_74HC153) += nxp_74hc153.o
+ obj-$(CONFIG_GPIO_PCA953X) += pca953x.o
+ obj-$(CONFIG_GPIO_PCF857X) += pcf857x.o
+ obj-$(CONFIG_GPIO_PL061) += pl061.o