aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-07 18:06:39 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-07 18:06:39 +0000
commit599081f3e41f2b3551a39e0f06edfe0d4d3fa836 (patch)
tree0a868ea5c6d9eed80b4dd8678d23e62859ba2fb6 /target/linux/ar71xx/image
parentd942d941619cebec65c441575bb0ad7d23758e43 (diff)
downloadmaster-187ad058-599081f3e41f2b3551a39e0f06edfe0d4d3fa836.tar.gz
master-187ad058-599081f3e41f2b3551a39e0f06edfe0d4d3fa836.tar.bz2
master-187ad058-599081f3e41f2b3551a39e0f06edfe0d4d3fa836.zip
ar71xx: Add support for Cisco-Linksys WAP4410N
This patch adds support for the Cisco WAP4410N, an access point that uses the AR9132 SoC. Web upgrades from stock are not yet possible, UART access required for the initial flash. Signed-off-by: Ryan A Young <rayoung@utexas.edu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46250 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 0235287e16..e43d95dd4a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1254,6 +1254,8 @@ define Image/Build/WRT400N
fi
endef
+Image/Build/WAP4410N/buildkernel=$(call MkuImageGzip,$(2),$(3))
+Image/Build/WAP4410N=$(call Sysupgrade/KRuImage,$(1),$(2),1638400,6356992)
define Image/Build/CameoAP94/buildkernel
$(call MkuImageLzma,$(2),$(3) $(4))
@@ -2141,6 +2143,7 @@ $(eval $(call SingleProfile,WHRHPG300N,64kraw,WHRHPGN,whr-hp-gn,WHR-HP-GN,ttyS0,
$(eval $(call SingleProfile,WHRHPG300N,64kraw,WLAEAG300N,wlae-ag300n,WLAE-AG300N,ttyS0,115200,$$(whrhpg300n_mtdlayout),WLAE-AG300N))
$(eval $(call SingleProfile,WRT400N,64k,WRT400N,wrt400n,WRT400N,ttyS0,115200))
+$(eval $(call SingleProfile,WAP4410N,64k,WAP4410N,wap4410n,WAP4410N,ttyS0,115200))
$(eval $(call SingleProfile,WZRHP128K,128kraw,WZRHPG300NH,wzr-hp-g300nh,WZR-HP-G300NH,ttyS0,115200,WZR-HP-G300NH))
$(eval $(call SingleProfile,WZRHP64K,64kraw,WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))