aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-28 17:47:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-28 17:47:33 +0000
commit0a88a341f2acec5db710a5310b7f05d6dd7a59a0 (patch)
treee90ff010c55a1f6069e5ad29d9580a064e34fe8f /target/linux/ar71xx/image
parentf62328db0eb2cc440a9b44df1a8295b7fdb452ca (diff)
downloadmaster-187ad058-0a88a341f2acec5db710a5310b7f05d6dd7a59a0.tar.gz
master-187ad058-0a88a341f2acec5db710a5310b7f05d6dd7a59a0.tar.bz2
master-187ad058-0a88a341f2acec5db710a5310b7f05d6dd7a59a0.zip
[ar71xx] add initial profiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14693 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c96456759c..720be1c1e0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -179,6 +179,16 @@ define Image/Build/Profile/TLWR941NDV2
$(call Image/Build/Template/TPLINK/$(1),tl-wr941ndv2,board=TL-WR941ND,TL-WR941NDv2)
endef
+define Image/Build/Profile/Default
+ $(call Image/Build/Profile/DIR615C1,$(1))
+ $(call Image/Build/Profile/MZKW04NU,$(1))
+ $(call Image/Build/Profile/TEW632BRP,$(1))
+ $(call Image/Build/Profile/TEW652BRP,$(1))
+ $(call Image/Build/Profile/TLWR941NDV2,$(1))
+ $(call Image/Build/Profile/UBNTRS,$(1))
+ $(call Image/Build/Profile/WP543,$(1))
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
@@ -187,13 +197,7 @@ define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(IMGNAME)-root.$(1) bs=128k conv=sync
- $(call Image/Build/Profile/DIR615C1,$(1))
- $(call Image/Build/Profile/MZKW04NU,$(1))
- $(call Image/Build/Profile/TEW632BRP,$(1))
- $(call Image/Build/Profile/TEW652BRP,$(1))
- $(call Image/Build/Profile/UBNTRS,$(1))
- $(call Image/Build/Profile/WP543,$(1))
- $(call Image/Build/Profile/TLWR941NDV2,$(1))
+ $(call Image/Build/Profile/$(PROFILE),$(1))
endef
$(eval $(call BuildImage))