aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
commit490b17495b54145fc7c10126f55c711af7ec0354 (patch)
treed12c3af1810a8f543c16e89c7bc114ed74d197bb /target/linux/ar71xx/image/Makefile
parentc44193f4c781df9bbd22e9f61b3eb10cbf8ad700 (diff)
downloadmaster-187ad058-490b17495b54145fc7c10126f55c711af7ec0354.tar.gz
master-187ad058-490b17495b54145fc7c10126f55c711af7ec0354.tar.bz2
master-187ad058-490b17495b54145fc7c10126f55c711af7ec0354.zip
image: move netgear-image to top and rename to -dni
Use the same naming as netgear-chk. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46791 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 04597f2c82..e6fe36ad09 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -37,15 +37,6 @@ define Build/netgear-uImage
$(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
endef
-define Build/netgear-image
- $(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
- $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
- -r "$(1)" \
- -i $@ -o $@.new
- mv $@.new $@
-endef
-
# combine kernel and rootfs into one image
# -a align the rootfs start on an <align> bytes boundary
# -j add jffs2 end-of-filesystem markers
@@ -198,8 +189,8 @@ define Device/wndr3700
KERNEL := kernel-bin | patch-cmdline | lzma -d20 | netgear-uImage lzma
IMAGE/default = append-kernel $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin = $$(IMAGE/default) | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.img = $$(IMAGE/default) | netgear-image | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory-NA.img = $$(IMAGE/default) | netgear-image NA | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.img = $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory-NA.img = $$(IMAGE/default) | netgear-dni NA | check-size $$$$(IMAGE_SIZE)
endef
define Device/wndr3700v2