aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-24 09:09:49 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-24 09:09:49 +0000
commit48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39 (patch)
tree1047392db4c045b6b2f3e454eff7057da6511d96 /target/linux/ar71xx/image/Makefile
parent8bf4a3fc9973498eef70d4c083b49bc3a8c56db0 (diff)
downloadmaster-187ad058-48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39.tar.gz
master-187ad058-48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39.tar.bz2
master-187ad058-48ed568e01d424ab21b9b81f4f5a3bdcf3ef1a39.zip
ar71xx: add support for Onion Omega
This patch adds support for the Onion Omega. https://onion.io/omega Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: Boken Lin <bl@onion.io> Tested-by: Jacky Huang <huangfangcheng@163.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46458 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index e7d22f6395..c2ebb8f0d3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -388,6 +388,15 @@ define Device/mc-mac1200r
endef
TARGET_DEVICES += mc-mac1200r
+define Device/onion-omega
+ $(Device/tplink-16mlzma)
+ BOARDNAME := ONION-OMEGA
+ DEVICE_PROFILE := OMEGA
+ TPLINK_HWID := 0x04700001
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += onion-omega
+
define Device/tl-mr10u-v1
$(Device/tplink-4mlzma)
BOARDNAME := TL-MR10U