aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:23 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 18:21:23 +0000
commit2a04e78e1f1dbb37b8378bbcd783dd20dbd584c1 (patch)
treee9e15100ed6dafdba0441577de5fb8391b8036ba /target/linux/ar71xx/image/Makefile
parentff43ce44d10f0f4bd835c100775a6ae4013793ae (diff)
downloadmaster-187ad058-2a04e78e1f1dbb37b8378bbcd783dd20dbd584c1.tar.gz
master-187ad058-2a04e78e1f1dbb37b8378bbcd783dd20dbd584c1.tar.bz2
master-187ad058-2a04e78e1f1dbb37b8378bbcd783dd20dbd584c1.zip
ar71xx: add support for TL-WR720N-v4.
The hardware should be almost the same as TL-WR720N-v3. WiFi and LAN networks were tested by "Lo Yuk Fai <loyukfai@gmail.com>". Failsafe and slider switch were tested by "Wong min <alpha080@gmail.com>". Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46046 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 57c58ace79..3483ee40bf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -492,7 +492,15 @@ define Device/tl-wr720n-v3
TPLINK_HWID := 0x07200103
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3
+
+define Device/tl-wr720n-v4
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR720N-v3
+ DEVICE_PROFILE := TLWR720
+ TPLINK_HWID := 0x07200104
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
define Device/tl-wr740n-v4
$(Device/tplink-4mlzma)