aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-13 20:57:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-13 20:57:15 +0000
commit1a6d0dbc956e4262cebe8e5c19a78d7e5eaed0e0 (patch)
treedce31041c602ca2a0d1ffb594c46e968f2dbf21a /target/linux/ar71xx/generic
parentf1d93b041960c3908051057e20c33971e81ef563 (diff)
downloadmaster-187ad058-1a6d0dbc956e4262cebe8e5c19a78d7e5eaed0e0.tar.gz
master-187ad058-1a6d0dbc956e4262cebe8e5c19a78d7e5eaed0e0.tar.bz2
master-187ad058-1a6d0dbc956e4262cebe8e5c19a78d7e5eaed0e0.zip
ar71xx: add profiles and build images for old PowerCloud System devices
[juhosg: - use 'PowerCloud Systems' instead of 'PCS' in the profiles - sort SingleProfile instances in image/Makefile] Signed-off-by: Daniel Dickinson <daniel@powercloudsystems.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34195 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/pcs.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/pcs.mk b/target/linux/ar71xx/generic/profiles/pcs.mk
new file mode 100644
index 0000000000..1399ef4233
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/pcs.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2012 PowerCloud Systems
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBDEV01
+ NAME:=PowerCloud Systems ubdev01 model
+ PACKAGES:=
+endef
+
+define Profile/UBDEV01/Description
+ Package set optimized for the PowerCloud Systems ubdev01 board.
+endef
+
+$(eval $(call Profile,UBDEV01))
+
+define Profile/DLRTDEV01
+ NAME:=PowerCloud Systems dlrtdev01 model
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DLRTDEV01/Description
+ Package set optimized for the PowerCloud Systems dlrtdev01 board.
+endef
+
+$(eval $(call Profile,DLRTDEV01))