aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.25/110-flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-19 07:06:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-19 07:06:35 +0000
commit249455db69bf558c386ba7bde050844e2f0ec2b3 (patch)
tree96c29c280eab70614388fc2b578b5a1668664603 /target/linux/ar7/patches-2.6.25/110-flash.patch
parent46dc775878ae30e4e08f56a735554693b4078db9 (diff)
downloadmaster-187ad058-249455db69bf558c386ba7bde050844e2f0ec2b3.tar.gz
master-187ad058-249455db69bf558c386ba7bde050844e2f0ec2b3.tar.bz2
master-187ad058-249455db69bf558c386ba7bde050844e2f0ec2b3.zip
[ar7] refresh kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11196 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/patches-2.6.25/110-flash.patch')
-rw-r--r--target/linux/ar7/patches-2.6.25/110-flash.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/target/linux/ar7/patches-2.6.25/110-flash.patch b/target/linux/ar7/patches-2.6.25/110-flash.patch
index 02f8d952f0..350fe167f5 100644
--- a/target/linux/ar7/patches-2.6.25/110-flash.patch
+++ b/target/linux/ar7/patches-2.6.25/110-flash.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.25.1/drivers/mtd/Kconfig
+Index: linux-2.6.25.4/drivers/mtd/Kconfig
===================================================================
---- linux-2.6.25.1.orig/drivers/mtd/Kconfig 2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/drivers/mtd/Kconfig 2008-05-03 16:18:06.000000000 +0200
-@@ -158,6 +158,12 @@
+--- linux-2.6.25.4.orig/drivers/mtd/Kconfig
++++ linux-2.6.25.4/drivers/mtd/Kconfig
+@@ -168,6 +168,12 @@ config MTD_OF_PARTS
the partition map from the children of the flash node,
as described in Documentation/powerpc/booting-without-of.txt.
@@ -15,11 +15,11 @@ Index: linux-2.6.25.1/drivers/mtd/Kconfig
comment "User Modules And Translation Layers"
config MTD_CHAR
-Index: linux-2.6.25.1/drivers/mtd/Makefile
+Index: linux-2.6.25.4/drivers/mtd/Makefile
===================================================================
---- linux-2.6.25.1.orig/drivers/mtd/Makefile 2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/drivers/mtd/Makefile 2008-05-03 16:18:06.000000000 +0200
-@@ -12,6 +12,7 @@
+--- linux-2.6.25.4.orig/drivers/mtd/Makefile
++++ linux-2.6.25.4/drivers/mtd/Makefile
+@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
@@ -27,11 +27,11 @@ Index: linux-2.6.25.1/drivers/mtd/Makefile
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
-Index: linux-2.6.25.1/drivers/mtd/maps/physmap.c
+Index: linux-2.6.25.4/drivers/mtd/maps/physmap.c
===================================================================
---- linux-2.6.25.1.orig/drivers/mtd/maps/physmap.c 2008-05-01 23:45:25.000000000 +0200
-+++ linux-2.6.25.1/drivers/mtd/maps/physmap.c 2008-05-03 16:18:06.000000000 +0200
-@@ -87,7 +87,8 @@
+--- linux-2.6.25.4.orig/drivers/mtd/maps/physmap.c
++++ linux-2.6.25.4/drivers/mtd/maps/physmap.c
+@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS