aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/image/Makefile
diff options
context:
space:
mode:
authorEugene Konev <ejka@openwrt.org>2007-10-22 14:20:02 +0000
committerEugene Konev <ejka@openwrt.org>2007-10-22 14:20:02 +0000
commit6427bfebf0bc74dc14280aa2d2e5c3b9e5f7646d (patch)
tree9dcdc6afa9e24d4d87c4e0bcdc0a245099c4f41f /target/linux/ar7/image/Makefile
parent8ce442bc2e2ba33d997b0ec7d17b16f38771c433 (diff)
downloadmaster-187ad058-6427bfebf0bc74dc14280aa2d2e5c3b9e5f7646d.tar.gz
master-187ad058-6427bfebf0bc74dc14280aa2d2e5c3b9e5f7646d.tar.bz2
master-187ad058-6427bfebf0bc74dc14280aa2d2e5c3b9e5f7646d.zip
ar7: add eva image generation (thanks Axel Gembe)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9401 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7/image/Makefile')
-rw-r--r--target/linux/ar7/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ar7/image/Makefile b/target/linux/ar7/image/Makefile
index b80af35408..702c7aad2d 100644
--- a/target/linux/ar7/image/Makefile
+++ b/target/linux/ar7/image/Makefile
@@ -64,6 +64,12 @@ endef
# rm -f "$(KDIR)/dgfw.tmp"
#endef
+define Image/Build/EVA
+ $(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_ENTRY) $(KERNEL_ENTRY) $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(KERNEL)-$(1).bin)
+endef
+
define Image/Build
dd if=$(KDIR)/loader.bin $(call align/$(1)) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
@@ -78,6 +84,7 @@ define Image/Build
$(call Image/Build/CyberTAN,$(1),WA7B,WA7B -b,$(1))
# $(call Image/Build/sErCoMm,$(1),dg834,$(1))
# $(call Image/Build/sErCoMm,$(1),jdr454wb,$(1))
+ $(call Image/Build/EVA,$(1),EVA)
endef
$(eval $(call BuildImage))