aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7-2.6/patches-2.6.22/130-leds.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-11 10:47:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-11 10:47:25 +0000
commit72ac953dafcf154bdd70e9c170fe195391ff5c3a (patch)
treecabca792e6f80c55a0505c596011c62e47a0be67 /target/linux/ar7-2.6/patches-2.6.22/130-leds.patch
parent33d8693b0d17b33bbe8f2176a334e858d5d9e2ae (diff)
downloadmaster-187ad058-72ac953dafcf154bdd70e9c170fe195391ff5c3a.tar.gz
master-187ad058-72ac953dafcf154bdd70e9c170fe195391ff5c3a.tar.bz2
master-187ad058-72ac953dafcf154bdd70e9c170fe195391ff5c3a.zip
add ar7 2.6.22 patches by matteo (work in progress, not booting yet)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7914 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7-2.6/patches-2.6.22/130-leds.patch')
-rw-r--r--target/linux/ar7-2.6/patches-2.6.22/130-leds.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ar7-2.6/patches-2.6.22/130-leds.patch b/target/linux/ar7-2.6/patches-2.6.22/130-leds.patch
new file mode 100644
index 0000000000..261b712196
--- /dev/null
+++ b/target/linux/ar7-2.6/patches-2.6.22/130-leds.patch
@@ -0,0 +1,27 @@
+diff -ruN linux-2.6.19.2-orig/drivers/leds/Kconfig linux-2.6.19.2-ar7/drivers/leds/Kconfig
+--- linux-2.6.19.2-orig/drivers/leds/Kconfig 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2-ar7/drivers/leds/Kconfig 2007-02-24 02:30:48.000000000 +0100
+@@ -19,6 +19,12 @@
+
+ comment "LED drivers"
+
++config LEDS_AR7
++ tristate "LED Support for the TI AR7"
++ depends LEDS_CLASS && AR7
++ help
++ This option enables support for the LEDs on TI AR7.
++
+ config LEDS_CORGI
+ tristate "LED Support for the Sharp SL-C7x0 series"
+ depends LEDS_CLASS && PXA_SHARP_C7xx
+diff -ruN linux-2.6.19.2-orig/drivers/leds/Makefile linux-2.6.19.2-ar7/drivers/leds/Makefile
+--- linux-2.6.19.2-orig/drivers/leds/Makefile 2007-01-10 20:10:37.000000000 +0100
++++ linux-2.6.19.2-ar7/drivers/leds/Makefile 2007-02-24 02:29:44.000000000 +0100
+@@ -5,6 +5,7 @@
+ obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
+
+ # LED Platform Drivers
++obj-$(CONFIG_LEDS_AR7) += leds-ar7.o
+ obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
+ obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
+ obj-$(CONFIG_LEDS_SPITZ) += leds-spitz.o