aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7-2.4/base-files.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-22 23:27:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-22 23:27:29 +0000
commit0cbe723631eed7e541483592d16b6d125c846674 (patch)
treedc8d648372e516e754590075b43f0dba98df8546 /target/linux/ar7-2.4/base-files.mk
parent36dbcb9b377d3b3576ff081f229dd437e84a92bf (diff)
downloadmaster-187ad058-0cbe723631eed7e541483592d16b6d125c846674.tar.gz
master-187ad058-0cbe723631eed7e541483592d16b6d125c846674.tar.bz2
master-187ad058-0cbe723631eed7e541483592d16b6d125c846674.zip
move platform specific base-files into target/linux/<targetname>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5621 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar7-2.4/base-files.mk')
-rw-r--r--target/linux/ar7-2.4/base-files.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar7-2.4/base-files.mk b/target/linux/ar7-2.4/base-files.mk
new file mode 100644
index 0000000000..f21a604b83
--- /dev/null
+++ b/target/linux/ar7-2.4/base-files.mk
@@ -0,0 +1,11 @@
+define Build/Compile
+ $(call Build/Compile/Default)
+ $(TARGET_CC) -o $(PKG_BUILD_DIR)/adam2patcher $(PLATFORM_DIR)/src/adam2patcher.c
+endef
+
+define Package/base-files/install-target
+ mkdir -p $(1)/sbin
+ $(CP) $(PKG_BUILD_DIR)/adam2patcher $(1)/sbin
+endef
+
+