aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-28 16:47:42 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-28 16:47:42 +0000
commit5ba9b4642ec0857358d8fddca06039e2fd19fac2 (patch)
treeca4596ca65fc35f9a4909c6ee6338325cd3a77be /target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch
parent643006d776d5bd95b51b01c71b60084f54844a6b (diff)
downloadmaster-187ad058-5ba9b4642ec0857358d8fddca06039e2fd19fac2.tar.gz
master-187ad058-5ba9b4642ec0857358d8fddca06039e2fd19fac2.tar.bz2
master-187ad058-5ba9b4642ec0857358d8fddca06039e2fd19fac2.zip
add support for the AMCC Taishan, mark it as broken until we fix the combined layout
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7377 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch')
-rw-r--r--target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch b/target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch
new file mode 100644
index 0000000000..b1f2707834
--- /dev/null
+++ b/target/linux/amcc-2.6/patches/120-uncompressed_uImage.patch
@@ -0,0 +1,17 @@
+diff -Nur linux-2.6.21/arch/ppc/boot/images/Makefile linux-2.6.21-owrt/arch/ppc/boot/images/Makefile
+--- linux-2.6.21/arch/ppc/boot/images/Makefile 2007-04-27 23:49:26.000000000 +0200
++++ linux-2.6.21-owrt/arch/ppc/boot/images/Makefile 2007-05-28 17:44:11.000000000 +0200
+@@ -20,11 +20,11 @@
+
+ quiet_cmd_uimage = UIMAGE $@
+ cmd_uimage = $(CONFIG_SHELL) $(MKIMAGE) -A ppc -O linux -T kernel \
+- -C gzip -a 00000000 -e 00000000 -n 'Linux-$(KERNELRELEASE)' \
++ -C none -a 00000000 -e 00000000 -n 'Linux-$(KERNELRELEASE)' \
+ -d $< $@
+
+ targets += uImage
+-$(obj)/uImage: $(obj)/vmlinux.gz
++$(obj)/uImage: $(obj)/vmlinux.bin
+ $(Q)rm -f $@
+ $(call cmd,uimage)
+ @echo -n ' Image: $@ '