aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amcc-2.6/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-28 16:47:42 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-28 16:47:42 +0000
commit5ba9b4642ec0857358d8fddca06039e2fd19fac2 (patch)
treeca4596ca65fc35f9a4909c6ee6338325cd3a77be /target/linux/amcc-2.6/image
parent643006d776d5bd95b51b01c71b60084f54844a6b (diff)
downloadmaster-187ad058-5ba9b4642ec0857358d8fddca06039e2fd19fac2.tar.gz
master-187ad058-5ba9b4642ec0857358d8fddca06039e2fd19fac2.tar.bz2
master-187ad058-5ba9b4642ec0857358d8fddca06039e2fd19fac2.zip
add support for the AMCC Taishan, mark it as broken until we fix the combined layout
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7377 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/amcc-2.6/image')
-rw-r--r--target/linux/amcc-2.6/image/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/amcc-2.6/image/Makefile b/target/linux/amcc-2.6/image/Makefile
new file mode 100644
index 0000000000..bab2e647ee
--- /dev/null
+++ b/target/linux/amcc-2.6/image/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+endef
+
+$(eval $(call BuildImage))