aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-05 00:19:40 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-05 00:19:40 +0000
commitf5ea60f000d1a53780c57b0a641201f317c63ced (patch)
treecfed792b13b23a8a2371990dcec6f534fea290ec /target/linux/amazon/image
parent491ce2c749fb73801794f9162227b37075bb250e (diff)
downloadmaster-187ad058-f5ea60f000d1a53780c57b0a641201f317c63ced.tar.gz
master-187ad058-f5ea60f000d1a53780c57b0a641201f317c63ced.tar.bz2
master-187ad058-f5ea60f000d1a53780c57b0a641201f317c63ced.zip
amazon: R.I.P.
its been broken for 2 1/2 years Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43516 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/amazon/image')
-rw-r--r--target/linux/amazon/image/Makefile30
1 files changed, 0 insertions, 30 deletions
diff --git a/target/linux/amazon/image/Makefile b/target/linux/amazon/image/Makefile
deleted file mode 100644
index 08f3ba531d..0000000000
--- a/target/linux/amazon/image/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Image/BuildKernel
- $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
- mkimage -A mips -O linux -T kernel -C lzma -a 0x80002000 -e \
- 0x80002000 \
- -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage
-
- cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(1).image)
-endef
-
-define Image/Build
- cat $(KDIR)/uImage $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).image
- $(call Image/Build/$(1),$(1))
-endef
-
-
-$(eval $(call BuildImage))