aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-04-10 15:08:28 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-04-10 15:08:28 +0000
commit8c8c51f5d53d451b9b1b65ee29bdd66f45dd9859 (patch)
tree333f3c15891a91643ba22329bf8622ab4ba87095 /target/linux/amazon/Makefile
parente90182d1e48ce40a167820baf8dd7a985d42a19a (diff)
downloadmaster-187ad058-8c8c51f5d53d451b9b1b65ee29bdd66f45dd9859.tar.gz
master-187ad058-8c8c51f5d53d451b9b1b65ee29bdd66f45dd9859.tar.bz2
master-187ad058-8c8c51f5d53d451b9b1b65ee29bdd66f45dd9859.zip
amazon: Upgrade amazon target to kernel 2.6.37
This was just a little bit tested on an SAMSUNG SMT-G3020 and pci and usb do not work like before. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26576 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/amazon/Makefile')
-rw-r--r--target/linux/amazon/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/amazon/Makefile b/target/linux/amazon/Makefile
index aae39a00e9..e90fc4c8bd 100644
--- a/target/linux/amazon/Makefile
+++ b/target/linux/amazon/Makefile
@@ -10,7 +10,7 @@ ARCH:=mips
BOARD:=amazon
BOARDNAME:=Infineon Amazon
FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.30.10
+LINUX_VERSION:=2.6.37.6
include $(INCLUDE_DIR)/target.mk
@@ -18,4 +18,10 @@ define Target/Description
Build firmware images for Infineon Amazon boards
endef
+define Kernel/Prepare
+ $(call Kernel/Prepare/Default)
+ mkdir -p $(LINUX_DIR)/arch/mips/include/asm/amazon
+ $(CP) $(LINUX_DIR)/include/asm-mips/amazon/*.h $(LINUX_DIR)/arch/mips/include/asm/amazon
+endef
+
$(eval $(call BuildTarget))