aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/amazon-2.6/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-07-23 22:10:11 +0000
committerJohn Crispin <blogic@openwrt.org>2007-07-23 22:10:11 +0000
commit357dcff318248ae2c193a094d5e2c5d5fe962c8e (patch)
tree4d1d8efac3cb27f369b02bf8b3fc8352369e053f /target/linux/amazon-2.6/image
parent0a9cc878be11847b461f020490894c46db67e9ec (diff)
downloadmaster-187ad058-357dcff318248ae2c193a094d5e2c5d5fe962c8e.tar.gz
master-187ad058-357dcff318248ae2c193a094d5e2c5d5fe962c8e.tar.bz2
master-187ad058-357dcff318248ae2c193a094d5e2c5d5fe962c8e.zip
initial merge of infineon code for amazon, pci is still broken a bit. a big thank you goes to infineon for providing info and reference code
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8137 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/amazon-2.6/image')
-rw-r--r--target/linux/amazon-2.6/image/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/amazon-2.6/image/Makefile b/target/linux/amazon-2.6/image/Makefile
new file mode 100644
index 0000000000..c749560db9
--- /dev/null
+++ b/target/linux/amazon-2.6/image/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ $(STAGING_DIR)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
+ mkimage -A mips -O linux -T kernel -C lzma -a 0x80002000 -e \
+ 0x80002000 \
+ -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/vmlinux.lzma $(KDIR)/uImage
+
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image)
+endef
+
+define Image/Build
+ cat $(KDIR)/uImage $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image
+ $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))