aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-11-06 18:54:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-11-06 18:54:20 +0000
commit7592e73bacd0deaf81c61daf22b89f6b2b584870 (patch)
tree92a03d56fe21fe784eae3ffca40cc36875b799e0 /target/linux/adm8668/Makefile
parent4cd045d79668d4ca706192b513992e6b1fda72cb (diff)
downloadmaster-187ad058-7592e73bacd0deaf81c61daf22b89f6b2b584870.tar.gz
master-187ad058-7592e73bacd0deaf81c61daf22b89f6b2b584870.tar.bz2
master-187ad058-7592e73bacd0deaf81c61daf22b89f6b2b584870.zip
Merge branch 'adm8668'
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23900 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm8668/Makefile')
-rw-r--r--target/linux/adm8668/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
new file mode 100644
index 0000000000..9021e39256
--- /dev/null
+++ b/target/linux/adm8668/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=adm8668
+BOARDNAME:=Infineon WildPass ADM8668
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.36
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
+# kmod-switch kmod-diag nvram
+
+define Target/Description
+ Build firmware images for Infineon WildPass (ADM8668) based routers
+ (e.g. T-Mobile branded Linksys WRTU54G-TM)
+endef
+
+$(eval $(call BuildTarget))