aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-06 20:55:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-06 20:55:33 +0000
commitd9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76 (patch)
tree902ba8bee0eeb73fdb63e9402112c8c0ff4fb12f /target/linux/adm5120
parent226d8cb16579aecaaf52228177a795e276bf8f06 (diff)
downloadmaster-187ad058-d9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76.tar.gz
master-187ad058-d9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76.tar.bz2
master-187ad058-d9d70c2ebb0ad11fc61be3e9bc7148fe2106ab76.zip
[kernel] refresh 2.6.26 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13135 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120')
-rw-r--r--target/linux/adm5120/patches-2.6.26/001-adm5120.patch6
-rw-r--r--target/linux/adm5120/patches-2.6.26/002-adm5120_flash.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.26/003-adm5120_switch.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.26/005-adm5120_usb.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.26/007-adm5120_pci.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.26/101-cfi_fixup_macronix_bootloc.patch6
-rw-r--r--target/linux/adm5120/patches-2.6.26/102-jedec_pmc_39lvxxx_chips.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.26/103-mtd_trxsplit.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.26/120-rb153_cf_driver.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.26/200-amba_pl010_hacks.patch58
-rw-r--r--target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch8
-rw-r--r--target/linux/adm5120/patches-2.6.26/203-gpio_leds_brightness.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.26/310-adm5120_wdt.patch4
15 files changed, 58 insertions, 58 deletions
diff --git a/target/linux/adm5120/patches-2.6.26/001-adm5120.patch b/target/linux/adm5120/patches-2.6.26/001-adm5120.patch
index 0661ee1ad9..1ba5db66e2 100644
--- a/target/linux/adm5120/patches-2.6.26/001-adm5120.patch
+++ b/target/linux/adm5120/patches-2.6.26/001-adm5120.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -18,6 +18,21 @@
+@@ -18,6 +18,21 @@ choice
prompt "System type"
default SGI_IP22
@@ -22,7 +22,7 @@
config MACH_ALCHEMY
bool "Alchemy processor based machines"
-@@ -687,6 +702,7 @@
+@@ -687,6 +702,7 @@ config WR_PPMC
endchoice
@@ -32,7 +32,7 @@
source "arch/mips/jazz/Kconfig"
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -174,6 +174,21 @@
+@@ -174,6 +174,21 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
#
diff --git a/target/linux/adm5120/patches-2.6.26/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.26/002-adm5120_flash.patch
index c6559f2448..d7535aeaa6 100644
--- a/target/linux/adm5120/patches-2.6.26/002-adm5120_flash.patch
+++ b/target/linux/adm5120/patches-2.6.26/002-adm5120_flash.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
-@@ -586,5 +586,9 @@
+@@ -586,5 +586,9 @@ config MTD_PLATRAM
This selection automatically selects the map_ram driver.
@@ -12,7 +12,7 @@
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
-@@ -44,6 +44,7 @@
+@@ -44,6 +44,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
diff --git a/target/linux/adm5120/patches-2.6.26/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.26/003-adm5120_switch.patch
index 38619a4da5..ac0c5e3059 100644
--- a/target/linux/adm5120/patches-2.6.26/003-adm5120_switch.patch
+++ b/target/linux/adm5120/patches-2.6.26/003-adm5120_switch.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
-@@ -613,6 +613,10 @@
+@@ -613,6 +613,10 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
@@ -13,7 +13,7 @@
depends on PCI && SGI_IP27
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
-@@ -186,6 +186,7 @@
+@@ -186,6 +186,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o
diff --git a/target/linux/adm5120/patches-2.6.26/005-adm5120_usb.patch b/target/linux/adm5120/patches-2.6.26/005-adm5120_usb.patch
index ae85e6468d..751af5a6b7 100644
--- a/target/linux/adm5120/patches-2.6.26/005-adm5120_usb.patch
+++ b/target/linux/adm5120/patches-2.6.26/005-adm5120_usb.patch
@@ -13,7 +13,7 @@
depends on USB
--- a/drivers/usb/host/Makefile
+++ b/drivers/usb/host/Makefile
-@@ -10,6 +10,7 @@
+@@ -10,6 +10,7 @@ isp1760-objs := isp1760-hcd.o isp1760-if
obj-$(CONFIG_PCI) += pci-quirks.o
@@ -23,7 +23,7 @@
obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o
--- a/drivers/usb/Makefile
+++ b/drivers/usb/Makefile
-@@ -16,6 +16,7 @@
+@@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/
obj-$(CONFIG_USB_SL811_HCD) += host/
obj-$(CONFIG_USB_U132_HCD) += host/
obj-$(CONFIG_USB_R8A66597_HCD) += host/
diff --git a/target/linux/adm5120/patches-2.6.26/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.26/007-adm5120_pci.patch
index cb46375abb..3df0f06baf 100644
--- a/target/linux/adm5120/patches-2.6.26/007-adm5120_pci.patch
+++ b/target/linux/adm5120/patches-2.6.26/007-adm5120_pci.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
-@@ -48,3 +48,4 @@
+@@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
diff --git a/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
index a0d363a9b1..1e3385d299 100644
--- a/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.26/009-adm5120_leds_switch_trigger.patch
@@ -1,6 +1,6 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -207,4 +207,12 @@
+@@ -207,4 +207,12 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
@@ -15,7 +15,7 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -30,3 +30,4 @@
+@@ -30,3 +30,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
diff --git a/target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch b/target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch
index e34f7dc775..17cd986aee 100644
--- a/target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch
+++ b/target/linux/adm5120/patches-2.6.26/100-mtd_myloder_partition_parser.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -174,6 +174,22 @@
+@@ -174,6 +174,22 @@ config MTD_AR7_PARTS
---help---
TI AR7 partitioning support
@@ -25,7 +25,7 @@
config MTD_CHAR
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@
+@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdli
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
diff --git a/target/linux/adm5120/patches-2.6.26/101-cfi_fixup_macronix_bootloc.patch b/target/linux/adm5120/patches-2.6.26/101-cfi_fixup_macronix_bootloc.patch
index de3def9161..65b34ac875 100644
--- a/target/linux/adm5120/patches-2.6.26/101-cfi_fixup_macronix_bootloc.patch
+++ b/target/linux/adm5120/patches-2.6.26/101-cfi_fixup_macronix_bootloc.patch
@@ -20,7 +20,7 @@
static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
static int cfi_amdstd_write_buffers(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -243,6 +250,41 @@
+@@ -243,6 +250,41 @@ static void fixup_s29gl032n_sectors(stru
}
}
@@ -62,7 +62,7 @@
static struct cfi_fixup cfi_fixup_table[] = {
{ CFI_MFR_ATMEL, CFI_ID_ANY, fixup_convert_atmel_pri, NULL },
#ifdef AMD_BOOTLOC_BUG
-@@ -278,6 +320,9 @@
+@@ -278,6 +320,9 @@ static struct cfi_fixup fixup_table[] =
*/
{ CFI_MFR_ANY, CFI_ID_ANY, fixup_use_erase_chip, NULL },
{ CFI_MFR_ATMEL, AT49BV6416, fixup_use_atmel_lock, NULL },
@@ -74,7 +74,7 @@
--- a/drivers/mtd/chips/Kconfig
+++ b/drivers/mtd/chips/Kconfig
-@@ -196,6 +196,14 @@
+@@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
provides support for one of those command sets, used on chips
including the AMD Am29LV320.
diff --git a/target/linux/adm5120/patches-2.6.26/102-jedec_pmc_39lvxxx_chips.patch b/target/linux/adm5120/patches-2.6.26/102-jedec_pmc_39lvxxx_chips.patch
index d08786355c..e84c44fc48 100644
--- a/target/linux/adm5120/patches-2.6.26/102-jedec_pmc_39lvxxx_chips.patch
+++ b/target/linux/adm5120/patches-2.6.26/102-jedec_pmc_39lvxxx_chips.patch
@@ -11,7 +11,7 @@
#define PM49FL002 0x006D
#define PM49FL004 0x006E
#define PM49FL008 0x006A
-@@ -1173,6 +1177,54 @@
+@@ -1173,6 +1177,54 @@ static const struct amd_flash_info jedec
ERASEINFO(0x02000,2),
ERASEINFO(0x04000,1),
}
diff --git a/target/linux/adm5120/patches-2.6.26/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.26/103-mtd_trxsplit.patch
index 267293aa56..e4c86908a8 100644
--- a/target/linux/adm5120/patches-2.6.26/103-mtd_trxsplit.patch
+++ b/target/linux/adm5120/patches-2.6.26/103-mtd_trxsplit.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -57,6 +57,11 @@
+@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
depends on MTD_PARTITIONS
default y
@@ -14,7 +14,7 @@
depends on MTD_PARTITIONS
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
diff --git a/target/linux/adm5120/patches-2.6.26/120-rb153_cf_driver.patch b/target/linux/adm5120/patches-2.6.26/120-rb153_cf_driver.patch
index 242c6dd989..e100181849 100644
--- a/target/linux/adm5120/patches-2.6.26/120-rb153_cf_driver.patch
+++ b/target/linux/adm5120/patches-2.6.26/120-rb153_cf_driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/ata/Makefile
+++ b/drivers/ata/Makefile
-@@ -72,6 +72,7 @@
+@@ -72,6 +72,7 @@ obj-$(CONFIG_PATA_BF54X) += pata_bf54x.o
obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o
obj-$(CONFIG_PATA_ICSIDE) += pata_icside.o
@@ -10,7 +10,7 @@
# Should be last but one libata driver
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
-@@ -566,6 +566,15 @@
+@@ -566,6 +566,15 @@ config PATA_RADISYS
If unsure, say N.
diff --git a/target/linux/adm5120/patches-2.6.26/200-amba_pl010_hacks.patch b/target/linux/adm5120/patches-2.6.26/200-amba_pl010_hacks.patch
index 39c1dea24c..18fbc69493 100644
--- a/target/linux/adm5120/patches-2.6.26/200-amba_pl010_hacks.patch
+++ b/target/linux/adm5120/patches-2.6.26/200-amba_pl010_hacks.patch
@@ -14,7 +14,7 @@
#define AMBA_ISR_PASS_LIMIT 256
-@@ -82,9 +81,9 @@
+@@ -82,9 +81,9 @@ static void pl010_stop_tx(struct uart_po
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -26,7 +26,7 @@
}
static void pl010_start_tx(struct uart_port *port)
-@@ -92,9 +91,9 @@
+@@ -92,9 +91,9 @@ static void pl010_start_tx(struct uart_p
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -38,7 +38,7 @@
}
static void pl010_stop_rx(struct uart_port *port)
-@@ -102,9 +101,9 @@
+@@ -102,9 +101,9 @@ static void pl010_stop_rx(struct uart_po
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -50,7 +50,7 @@
}
static void pl010_enable_ms(struct uart_port *port)
-@@ -112,9 +111,9 @@
+@@ -112,9 +111,9 @@ static void pl010_enable_ms(struct uart_
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -62,7 +62,7 @@
}
static void pl010_rx_chars(struct uart_amba_port *uap)
-@@ -122,9 +121,9 @@
+@@ -122,9 +121,9 @@ static void pl010_rx_chars(struct uart_a
struct tty_struct *tty = uap->port.info->tty;
unsigned int status, ch, flag, rsr, max_count = 256;
@@ -74,7 +74,7 @@
flag = TTY_NORMAL;
uap->port.icount.rx++;
-@@ -133,9 +132,9 @@
+@@ -133,9 +132,9 @@ static void pl010_rx_chars(struct uart_a
* Note that the error handling code is
* out of the main execution path
*/
@@ -86,7 +86,7 @@
if (rsr & UART01x_RSR_BE) {
rsr &= ~(UART01x_RSR_FE | UART01x_RSR_PE);
-@@ -165,7 +164,7 @@
+@@ -165,7 +164,7 @@ static void pl010_rx_chars(struct uart_a
uart_insert_char(&uap->port, rsr, UART01x_RSR_OE, ch, flag);
ignore_char:
@@ -95,7 +95,7 @@
}
spin_unlock(&uap->port.lock);
tty_flip_buffer_push(tty);
-@@ -178,7 +177,7 @@
+@@ -178,7 +177,7 @@ static void pl010_tx_chars(struct uart_a
int count;
if (uap->port.x_char) {
@@ -104,7 +104,7 @@
uap->port.icount.tx++;
uap->port.x_char = 0;
return;
-@@ -190,7 +189,7 @@
+@@ -190,7 +189,7 @@ static void pl010_tx_chars(struct uart_a
count = uap->port.fifosize >> 1;
do {
@@ -113,7 +113,7 @@
xmit->tail = (xmit->tail + 1) & (UART_XMIT_SIZE - 1);
uap->port.icount.tx++;
if (uart_circ_empty(xmit))
-@@ -208,9 +207,9 @@
+@@ -208,9 +207,9 @@ static void pl010_modem_status(struct ua
{
unsigned int status, delta;
@@ -125,7 +125,7 @@
delta = status ^ uap->old_status;
uap->old_status = status;
-@@ -238,7 +237,7 @@
+@@ -238,7 +237,7 @@ static irqreturn_t pl010_int(int irq, vo
spin_lock(&uap->port.lock);
@@ -134,7 +134,7 @@
if (status) {
do {
if (status & (UART010_IIR_RTIS | UART010_IIR_RIS))
-@@ -251,7 +250,7 @@
+@@ -251,7 +250,7 @@ static irqreturn_t pl010_int(int irq, vo
if (pass_counter-- == 0)
break;
@@ -143,7 +143,7 @@
} while (status & (UART010_IIR_RTIS | UART010_IIR_RIS |
UART010_IIR_TIS));
handled = 1;
-@@ -265,7 +264,7 @@
+@@ -265,7 +264,7 @@ static irqreturn_t pl010_int(int irq, vo
static unsigned int pl010_tx_empty(struct uart_port *port)
{
struct uart_amba_port *uap = (struct uart_amba_port *)port;
@@ -152,7 +152,7 @@
return status & UART01x_FR_BUSY ? 0 : TIOCSER_TEMT;
}
-@@ -275,7 +274,7 @@
+@@ -275,7 +274,7 @@ static unsigned int pl010_get_mctrl(stru
unsigned int result = 0;
unsigned int status;
@@ -161,7 +161,7 @@
if (status & UART01x_FR_DCD)
result |= TIOCM_CAR;
if (status & UART01x_FR_DSR)
-@@ -301,12 +300,12 @@
+@@ -301,12 +300,12 @@ static void pl010_break_ctl(struct uart_
unsigned int lcr_h;
spin_lock_irqsave(&uap->port.lock, flags);
@@ -176,7 +176,7 @@
spin_unlock_irqrestore(&uap->port.lock, flags);
}
-@@ -334,12 +333,12 @@
+@@ -334,12 +333,12 @@ static int pl010_startup(struct uart_por
/*
* initialise the old status of the modem signals
*/
@@ -191,7 +191,7 @@
uap->port.membase + UART010_CR);
return 0;
-@@ -362,10 +361,10 @@
+@@ -362,10 +361,10 @@ static void pl010_shutdown(struct uart_p
/*
* disable all interrupts, disable the port
*/
@@ -204,7 +204,7 @@
~(UART01x_LCRH_BRK | UART01x_LCRH_FEN),
uap->port.membase + UART010_LCRH);
-@@ -387,7 +386,7 @@
+@@ -387,7 +386,7 @@ pl010_set_termios(struct uart_port *port
/*
* Ask the core to calculate the divisor for us.
*/
@@ -213,7 +213,7 @@
quot = uart_get_divisor(port, baud);
switch (termios->c_cflag & CSIZE) {
-@@ -450,25 +449,25 @@
+@@ -450,25 +449,25 @@ pl010_set_termios(struct uart_port *port
uap->port.ignore_status_mask |= UART_DUMMY_RSR_RX;
/* first, disable everything */
@@ -245,7 +245,7 @@
spin_unlock_irqrestore(&uap->port.lock, flags);
}
-@@ -540,7 +539,7 @@
+@@ -540,7 +539,7 @@ static struct uart_ops amba_pl010_pops =
.verify_port = pl010_verify_port,
};
@@ -254,7 +254,7 @@
#ifdef CONFIG_SERIAL_AMBA_PL010_CONSOLE
-@@ -550,10 +549,10 @@
+@@ -550,10 +549,10 @@ static void pl010_console_putchar(struct
unsigned int status;
do {
@@ -267,7 +267,7 @@
}
static void
-@@ -567,8 +566,8 @@
+@@ -567,8 +566,8 @@ pl010_console_write(struct console *co,
/*
* First save the CR then disable the interrupts
*/
@@ -278,7 +278,7 @@
uart_console_write(&uap->port, s, count, pl010_console_putchar);
-@@ -577,10 +576,10 @@
+@@ -577,10 +576,10 @@ pl010_console_write(struct console *co,
* and restore the TCR
*/
do {
@@ -291,7 +291,7 @@
clk_disable(uap->clk);
}
-@@ -589,9 +588,9 @@
+@@ -589,9 +588,9 @@ static void __init
pl010_console_get_options(struct uart_amba_port *uap, int *baud,
int *parity, int *bits)
{
@@ -303,7 +303,7 @@
*parity = 'n';
if (lcr_h & UART01x_LCRH_PEN) {
-@@ -606,8 +605,8 @@
+@@ -606,8 +605,8 @@ pl010_console_get_options(struct uart_am
else
*bits = 8;
@@ -314,7 +314,7 @@
*baud = uap->port.uartclk / (16 * (quot + 1));
}
}
-@@ -625,7 +624,7 @@
+@@ -625,7 +624,7 @@ static int __init pl010_console_setup(st
* if so, search for the first available port that does have
* console support.
*/
@@ -323,7 +323,7 @@
co->index = 0;
uap = amba_ports[co->index];
if (!uap)
-@@ -643,7 +642,7 @@
+@@ -643,7 +642,7 @@ static int __init pl010_console_setup(st
static struct uart_driver amba_reg;
static struct console amba_console = {
@@ -332,7 +332,7 @@
.write = pl010_console_write,
.device = uart_console_device,
.setup = pl010_console_setup,
-@@ -659,11 +658,11 @@
+@@ -659,11 +658,11 @@ static struct console amba_console = {
static struct uart_driver amba_reg = {
.owner = THIS_MODULE,
@@ -349,7 +349,7 @@
--- a/drivers/serial/Kconfig
+++ b/drivers/serial/Kconfig
-@@ -287,10 +287,25 @@
+@@ -287,10 +287,25 @@ config SERIAL_AMBA_PL010
help
This selects the ARM(R) AMBA(R) PrimeCell PL010 UART. If you have
an Integrator/AP or Integrator/PP2 platform, or if you have a
diff --git a/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch b/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch
index 40728a9707..b13a779bbf 100644
--- a/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch
+++ b/target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch
@@ -1,6 +1,6 @@
--- a/drivers/pci/Kconfig
+++ b/drivers/pci/Kconfig
-@@ -42,6 +42,12 @@
+@@ -42,6 +42,12 @@ config PCI_DEBUG
When in doubt, say N.
@@ -23,7 +23,7 @@
/* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device.
-@@ -1495,6 +1496,7 @@
+@@ -1495,6 +1496,7 @@ static void __devinit fixup_rev1_53c810(
}
}
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@@ -31,7 +31,7 @@
static void pci_do_fixups(struct pci_dev *dev, struct pci_fixup *f, struct pci_fixup *end)
{
-@@ -1561,6 +1563,7 @@
+@@ -1561,6 +1563,7 @@ void pci_fixup_device(enum pci_fixup_pas
}
EXPORT_SYMBOL(pci_fixup_device);
@@ -39,7 +39,7 @@
/* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{
-@@ -1934,3 +1937,4 @@
+@@ -1934,3 +1937,4 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_AT
quirk_msi_intx_disable_bug);
#endif /* CONFIG_PCI_MSI */
diff --git a/target/linux/adm5120/patches-2.6.26/203-gpio_leds_brightness.patch b/target/linux/adm5120/patches-2.6.26/203-gpio_leds_brightness.patch
index 5a3c11aabe..bb94fd05ea 100644
--- a/target/linux/adm5120/patches-2.6.26/203-gpio_leds_brightness.patch
+++ b/target/linux/adm5120/patches-2.6.26/203-gpio_leds_brightness.patch
@@ -1,6 +1,6 @@
--- a/drivers/leds/leds-gpio.c
+++ b/drivers/leds/leds-gpio.c
-@@ -43,13 +43,17 @@
+@@ -43,13 +43,17 @@ static void gpio_led_set(struct led_clas
container_of(led_cdev, struct gpio_led_data, cdev);
int level;
diff --git a/target/linux/adm5120/patches-2.6.26/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.26/310-adm5120_wdt.patch
index 423b130cc3..f6822ecd31 100644
--- a/target/linux/adm5120/patches-2.6.26/310-adm5120_wdt.patch
+++ b/target/linux/adm5120/patches-2.6.26/310-adm5120_wdt.patch
@@ -1,6 +1,6 @@
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
-@@ -632,6 +632,18 @@
+@@ -632,6 +632,18 @@ config SBC_EPX_C3_WATCHDOG
# MIPS Architecture
@@ -21,7 +21,7 @@
depends on SGI_HAS_INDYDOG
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
-@@ -91,6 +91,7 @@
+@@ -91,6 +91,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
# M68KNOMMU Architecture
# MIPS Architecture