aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-27 08:46:13 +0000
commit535270a5d43ad39e41c23272b5a2e8c654f9c7f7 (patch)
treeaa238bd29ae75fe2f49e391bbb1c60e934a6f8da /target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch
parentc3849fdfbdcab7486a1004833cb3594548f18b77 (diff)
downloadmaster-187ad058-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.tar.gz
master-187ad058-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.tar.bz2
master-187ad058-535270a5d43ad39e41c23272b5a2e8c654f9c7f7.zip
adm5120: add 2.6.33 & 2.6.34 kernel support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch
new file mode 100644
index 0000000000..91bd79d761
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -55,6 +55,7 @@ obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capc
+ obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+ obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
+ obj-$(CONFIG_CPU_CAVIUM_OCTEON) += pci-octeon.o pcie-octeon.o
++obj-$(CONFIG_ADM5120) += pci-adm5120.o
+
+ ifdef CONFIG_PCI_MSI
+ obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1748,6 +1748,9 @@
+ #define PCI_VENDOR_ID_ESDGMBH 0x12fe
+ #define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+
++#define PCI_VENDOR_ID_ADMTEK 0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
++
+ #define PCI_VENDOR_ID_SIIG 0x131f
+ #define PCI_SUBVENDOR_ID_SIIG 0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000