aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.25/002-adm5120_flash.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-02 08:52:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-02 08:52:37 +0000
commit5c09219b13a1f3695729cc24ac7e8390859a406f (patch)
treedb606b7cd5b45a08977f18014988bf56dab83ba0 /target/linux/adm5120/patches-2.6.25/002-adm5120_flash.patch
parent7e38adf97fc745ad3599875f07a67bf58062115d (diff)
downloadmaster-187ad058-5c09219b13a1f3695729cc24ac7e8390859a406f.tar.gz
master-187ad058-5c09219b13a1f3695729cc24ac7e8390859a406f.tar.bz2
master-187ad058-5c09219b13a1f3695729cc24ac7e8390859a406f.zip
[adm5120] add initial support for 2.6.25
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11005 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.25/002-adm5120_flash.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.25/002-adm5120_flash.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.25/002-adm5120_flash.patch b/target/linux/adm5120/patches-2.6.25/002-adm5120_flash.patch
new file mode 100644
index 0000000000..f23ebaac2c
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.25/002-adm5120_flash.patch
@@ -0,0 +1,26 @@
+Index: linux-2.6.25/drivers/mtd/maps/Kconfig
+===================================================================
+--- linux-2.6.25.orig/drivers/mtd/maps/Kconfig
++++ linux-2.6.25/drivers/mtd/maps/Kconfig
+@@ -590,5 +590,9 @@ config MTD_PLATRAM
+
+ This selection automatically selects the map_ram driver.
+
++config MTD_ADM5120
++ tristate "Map driver for ADM5120 based boards"
++ depends on MIPS_ADM5120
++
+ endmenu
+
+Index: linux-2.6.25/drivers/mtd/maps/Makefile
+===================================================================
+--- linux-2.6.25.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.25/drivers/mtd/maps/Makefile
+@@ -44,6 +44,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
+ obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
+ obj-$(CONFIG_MTD_PCI) += pci.o
+ obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
++obj-$(CONFIG_MTD_ADM5120) += adm5120-flash.o
+ obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
+ obj-$(CONFIG_MTD_EDB7312) += edb7312.o
+ obj-$(CONFIG_MTD_IMPA7) += impa7.o