aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.24/003-adm5120_switch.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-01-30 15:25:48 +0000
commitcb6ae8cb76641181d435bdb4220119343892e3f5 (patch)
tree483bb26f5be14c67ed308caaad451e75cd3a92e1 /target/linux/adm5120/patches-2.6.24/003-adm5120_switch.patch
parent0055d6efe2e51983fa506e6077710f43b20e011c (diff)
downloadmaster-187ad058-cb6ae8cb76641181d435bdb4220119343892e3f5.tar.gz
master-187ad058-cb6ae8cb76641181d435bdb4220119343892e3f5.tar.bz2
master-187ad058-cb6ae8cb76641181d435bdb4220119343892e3f5.zip
[adm5120] add preliminary support for 2.6.24
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10329 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120/patches-2.6.24/003-adm5120_switch.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.24/003-adm5120_switch.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.24/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.24/003-adm5120_switch.patch
new file mode 100644
index 0000000000..6a14c2b376
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.24/003-adm5120_switch.patch
@@ -0,0 +1,27 @@
+Index: linux-2.6.24/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.24.orig/drivers/net/Kconfig
++++ linux-2.6.24/drivers/net/Kconfig
+@@ -601,6 +601,10 @@ config MIPS_AU1X00_ENET
+ If you have an Alchemy Semi AU1X00 based system
+ say Y. Otherwise, say N.
+
++config MIPS_ADM5120_ENET
++ tristate "MIPS ADM5120 Ethernet switch support"
++ depends on MIPS_ADM5120
++
+ config SGI_IOC3_ETH
+ bool "SGI IOC3 Ethernet"
+ depends on PCI && SGI_IP27
+Index: linux-2.6.24/drivers/net/Makefile
+===================================================================
+--- linux-2.6.24.orig/drivers/net/Makefile
++++ linux-2.6.24/drivers/net/Makefile
+@@ -183,6 +183,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+ # This is also a 82596 and should probably be merged
+ obj-$(CONFIG_LP486E) += lp486e.o
+
++obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
+ obj-$(CONFIG_ETH16I) += eth16i.o
+ obj-$(CONFIG_ZORRO8390) += zorro8390.o
+ obj-$(CONFIG_HPLANCE) += hplance.o 7990.o