aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/patches
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-06-27 18:22:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-06-27 18:22:38 +0000
commitce91a059bbe9131aafc77b25a75b2a56a6e878a8 (patch)
treeb797ad9b7ae34d9d783e1600c2cdee8036a57742 /target/linux/adm5120-2.6/patches
parent1026bb5d7ee1b8af15e5a85c6d0c4601442ac3bb (diff)
downloadmaster-187ad058-ce91a059bbe9131aafc77b25a75b2a56a6e878a8.tar.gz
master-187ad058-ce91a059bbe9131aafc77b25a75b2a56a6e878a8.tar.bz2
master-187ad058-ce91a059bbe9131aafc77b25a75b2a56a6e878a8.zip
[adm5120] replace led driver, and resync kernel config
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7744 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120-2.6/patches')
-rw-r--r--target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch27
-rw-r--r--target/linux/adm5120-2.6/patches/006-adm5120_leds.patch45
2 files changed, 45 insertions, 27 deletions
diff --git a/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch b/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch
deleted file mode 100644
index 15a5eabf16..0000000000
--- a/target/linux/adm5120-2.6/patches/006-adm5120_gpio.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Index: linux-2.6.21.1/drivers/char/Kconfig
-===================================================================
---- linux-2.6.21.1.orig/drivers/char/Kconfig
-+++ linux-2.6.21.1/drivers/char/Kconfig
-@@ -1056,7 +1056,9 @@ config MMTIMER
- The mmtimer device allows direct userspace access to the
- Altix system timer.
-
--source "drivers/char/tpm/Kconfig"
-+config ADM5120_GPIO
-+ tristate "ADM5120 GPIO"
-+ depends on MIPS_ADM5120
-
- config TELCLOCK
- tristate "Telecom clock driver for ATCA SBC"
-Index: linux-2.6.21.1/drivers/char/Makefile
-===================================================================
---- linux-2.6.21.1.orig/drivers/char/Makefile
-+++ linux-2.6.21.1/drivers/char/Makefile
-@@ -93,6 +93,7 @@ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio
- obj-$(CONFIG_GPIO_VR41XX) += vr41xx_giu.o
- obj-$(CONFIG_TANBAC_TB0219) += tb0219.o
- obj-$(CONFIG_TELCLOCK) += tlclk.o
-+obj-$(CONFIG_ADM5120_GPIO) += adm5120_gpio.o
-
- obj-$(CONFIG_WATCHDOG) += watchdog/
- obj-$(CONFIG_MWAVE) += mwave/
diff --git a/target/linux/adm5120-2.6/patches/006-adm5120_leds.patch b/target/linux/adm5120-2.6/patches/006-adm5120_leds.patch
new file mode 100644
index 0000000000..ac654a017e
--- /dev/null
+++ b/target/linux/adm5120-2.6/patches/006-adm5120_leds.patch
@@ -0,0 +1,45 @@
+Index: linux-2.6.21.1/drivers/leds/Kconfig
+===================================================================
+--- linux-2.6.21.1.orig/drivers/leds/Kconfig
++++ linux-2.6.21.1/drivers/leds/Kconfig
+@@ -19,6 +19,27 @@ config LEDS_CLASS
+
+ comment "LED drivers"
+
++config LEDS_GPIO
++ tristate "LED support for LEDS on GPIO lines"
++ depends on LEDS_CLASS && GENERIC_GPIO
++ help
++ This option enables support for LEDs connected to GPIO lines
++
++config LEDS_ADM5120
++ tristate "LED Support for ADM5120 GPIO LEDs"
++ depends on LEDS_GPIO && MIPS_ADM5120
++ help
++ This option enables support for LEDs connected to GPIO lines
++ on ADM5120 SoC based platforms.
++
++config LEDS_ADM5120_EXPERIMENTAL
++ bool "Enable ADM5120 LEDs experimental code"
++ depends on LEDS_ADM5120
++
++config LEDS_ADM5120_DIAG
++ bool "Enable ADM5120 LEDs diagnostic mode"
++ depends on LEDS_ADM5120
++
+ config LEDS_CORGI
+ tristate "LED Support for the Sharp SL-C7x0 series"
+ depends on LEDS_CLASS && PXA_SHARP_C7xx
+Index: linux-2.6.21.1/drivers/leds/Makefile
+===================================================================
+--- linux-2.6.21.1.orig/drivers/leds/Makefile
++++ linux-2.6.21.1/drivers/leds/Makefile
+@@ -5,6 +5,8 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
+ obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
+
+ # LED Platform Drivers
++obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
++obj-$(CONFIG_LEDS_ADM5120) += leds-adm5120.o
+ obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
+ obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
+ obj-$(CONFIG_LEDS_SPITZ) += leds-spitz.o