aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/image/lzma-loader/src/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-07-15 15:02:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-07-15 15:02:38 +0000
commit8e8ccb8ddcd59a6acfe7ea647b25378d2c696033 (patch)
tree7ce47c5a47830caff3fe9dbead3a9dfb444f9f1f /target/linux/adm5120-2.6/image/lzma-loader/src/Makefile
parentb85e93eacda82538fd57e73c1bd64b8eac51eba3 (diff)
downloadmaster-187ad058-8e8ccb8ddcd59a6acfe7ea647b25378d2c696033.tar.gz
master-187ad058-8e8ccb8ddcd59a6acfe7ea647b25378d2c696033.tar.bz2
master-187ad058-8e8ccb8ddcd59a6acfe7ea647b25378d2c696033.zip
[adm5120] lzma-loader improvements
* update LzmaDecode.[ch] to 4.16 * speed up decompressing from flash * uses printf from lzma-loader of generic-2.6 target * initial support for flash bank switching git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7975 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120-2.6/image/lzma-loader/src/Makefile')
-rw-r--r--target/linux/adm5120-2.6/image/lzma-loader/src/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/adm5120-2.6/image/lzma-loader/src/Makefile b/target/linux/adm5120-2.6/image/lzma-loader/src/Makefile
index a3749f2ee9..7e9d8d03e4 100644
--- a/target/linux/adm5120-2.6/image/lzma-loader/src/Makefile
+++ b/target/linux/adm5120-2.6/image/lzma-loader/src/Makefile
@@ -38,6 +38,7 @@ BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic \
-ffunction-sections -pipe -mlong-calls -fno-common \
+ -ffreestanding \
-mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
CFLAGS += -DLOADADDR=$(LOADADDR)
@@ -48,7 +49,7 @@ LDFLAGS += -e startup -T loader.lds -Ttext $(LZMA_TEXT_START)
O_FORMAT = $(shell $(OBJDUMP) -i | head -2 | grep elf32)
-OBJECTS := head.o decompress.o board.o LzmaDecode.o
+OBJECTS := head.o decompress.o board.o printf.o LzmaDecode.o
ifneq ($(strip $(LOADER_DATA)),)
OBJECTS += data.o