aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-03-21 15:04:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-03-21 15:04:07 +0000
commit9881eea43e05cd063266f7e3fa6c9c7d822c70f4 (patch)
tree56f60cc676d7ff4685af71ee7272014d32a9f096 /target/linux/adm5120-2.6/image/Makefile
parentce65b07441aa8bd6efb9908991b1b50cdf8d9781 (diff)
downloadmaster-187ad058-9881eea43e05cd063266f7e3fa6c9c7d822c70f4.tar.gz
master-187ad058-9881eea43e05cd063266f7e3fa6c9c7d822c70f4.tar.bz2
master-187ad058-9881eea43e05cd063266f7e3fa6c9c7d822c70f4.zip
Add image generation for edimax routers
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6627 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120-2.6/image/Makefile')
-rw-r--r--target/linux/adm5120-2.6/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index 2043ffa9e5..a41fde9330 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -34,8 +34,21 @@ define trxalign/squashfs
-a 1024
endef
+define Image/Build/Compex
+ $(CP) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).trx
+endef
+
+define Image/Build/Edimax
+ $(STAGING_DIR)/bin/mksyshdr csys $(KDIR)/vmlinux
+ cat csys $(KDIR)/vmlinux $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+endef
+
define Image/Build
$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+ifneq ($(1),jffs2-128K)
+ $(call Image/Build/Compex,$(1),wp54g,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/Edimax,$(1),br6104,$(patsubst jffs2-%,jffs2,$(1)))
+endif
endef
$(eval $(call BuildImage))