aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-19 18:20:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-19 18:20:56 +0000
commit85c3d5e4f1b7edab7dd8f3d9ae561ada6a1b7533 (patch)
tree21edfebe032f5399b3d2f5e9d2f5a845982a2356 /target/linux/adm5120-2.6/image/Makefile
parent28a162aa228908a3fff7ab09537fd4316bc53d6c (diff)
downloadmaster-187ad058-85c3d5e4f1b7edab7dd8f3d9ae561ada6a1b7533.tar.gz
master-187ad058-85c3d5e4f1b7edab7dd8f3d9ae561ada6a1b7533.tar.bz2
master-187ad058-85c3d5e4f1b7edab7dd8f3d9ae561ada6a1b7533.zip
really fix tgz images
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8065 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120-2.6/image/Makefile')
-rw-r--r--target/linux/adm5120-2.6/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index b9ae44ecb4..829ddef3da 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -121,10 +121,13 @@ endif
endif
endif
endif
-ifeq ($(1),tgz)
+endef
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ define Image/BuildKernel
$(call Image/Build/RouterBoard)
+ endef
endif
-endef
define Image/Build/LZMAKernel
$(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \