aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-07-09 16:36:19 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-07-09 16:36:19 +0000
commit358221dfd2c339569bff2b5d6d8a4002915f6e69 (patch)
tree09caaf47b74e143bca20cf1a0e8d66e04ab31a67 /target/linux/adm5120-2.6/image/Makefile
parente6bfb6d91229cbbb7af994dcb73ceba3e42ea1a5 (diff)
downloadmaster-187ad058-358221dfd2c339569bff2b5d6d8a4002915f6e69.tar.gz
master-187ad058-358221dfd2c339569bff2b5d6d8a4002915f6e69.tar.bz2
master-187ad058-358221dfd2c339569bff2b5d6d8a4002915f6e69.zip
disable image generation for boards which we still have problems with (at least if CONFIG_DEVEL is not selected)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7902 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/adm5120-2.6/image/Makefile')
-rw-r--r--target/linux/adm5120-2.6/image/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index 732b82de3e..352ebf480f 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -82,7 +82,7 @@ root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
endef
define Image/Build/RouterBoard
- $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-vmlinux
+ $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-rb1xx-vmlinux
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
endef
@@ -91,6 +91,7 @@ define Image/Build
ifneq ($(1),jffs2-256k)
ifneq ($(1),jffs2-128k)
$(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
+ifeq (CONFIG_DEVEL,y)
$(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
$(call Image/Build/Edimax,$(1),br-6104kp,$(patsubst jffs2-%,jffs2,$(1)),BR-6104KP)
$(call Image/Build/Edimax,$(1),br-6114wg,$(patsubst jffs2-%,jffs2,$(1)),BR-6114WG)
@@ -117,6 +118,7 @@ ifneq ($(1),jffs2-128k)
$(call Image/Build/MyLoader,$(1),wpp54ag,$(patsubst jffs2-%,jffs2,$(1)),WPP54AG)
endif
endif
+endif
ifeq ($(1),tgz)
$(call Image/Build/RouterBoard)
endif
@@ -143,12 +145,17 @@ define Image/Build/LZMAKernel/Admboot
$(call Image/Build/LZMAKernel,$(1),$(2),0x80500000,0x6D8,y,$(1))
endef
+define Image/Build/Initramfs/RouterBoard
+ $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-ramfs-rb1xx.elf
+endef
+
define Image/Build/Initramfs
+ $(call Image/Build/Initramfs/RouterBoard)
+ $(call Image/Build/LZMAKernel/Compex,wp54g-wrt,bin)
+ifeq (CONFIG_DEVEL,y)
$(call Image/Build/LZMAKernel/Generic,generic,bin)
- $(call Image/Build/LZMAKernel/Generic,rb-100,elf)
$(call Image/Build/LZMAKernel/Generic,np27g,bin)
$(call Image/Build/LZMAKernel/Generic,wp54g,bin)
- $(call Image/Build/LZMAKernel/Compex,wp54g-wrt,bin)
$(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
$(call Image/Build/LZMAKernel/Admboot,easy-5120,gz)
$(call Image/Build/LZMAKernel/Admboot,easy-83000,gz)
@@ -158,6 +165,7 @@ define Image/Build/Initramfs
$(call Image/Build/LZMAKernel/Admboot,cas-771,gz)
$(call Image/Build/LZMAKernel/Admboot,cas-790,gz)
$(call Image/Build/LZMAKernel/Admboot,cas-861,gz)
+endif
endef
$(eval $(call BuildImage))