aboutsummaryrefslogtreecommitdiffstats
path: root/target/imagebuilder/files/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-08 00:36:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-08 00:36:35 +0000
commitc2739d2e24a5e0c0cf1563509374781955d9b9ad (patch)
tree0cd524ba71085d2707940f9521147c62f32d4407 /target/imagebuilder/files/Makefile
parenta5bd37b0f6177da1dfbb018f0221066de5c52759 (diff)
downloadmaster-187ad058-c2739d2e24a5e0c0cf1563509374781955d9b9ad.tar.gz
master-187ad058-c2739d2e24a5e0c0cf1563509374781955d9b9ad.tar.bz2
master-187ad058-c2739d2e24a5e0c0cf1563509374781955d9b9ad.zip
[imagebuilder]
- add a helper script to generate opkg.conf, attempt to detect package architecture from packages/ - fix package defaults when no package override is given, IB previously aggregated the defautls of all profiles - introduce a repositories.conf, allows using remote opkg repositories in imagebuilder git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22978 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/imagebuilder/files/Makefile')
-rw-r--r--target/imagebuilder/files/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 8e6c6d7462..0590dfa72c 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -86,19 +86,12 @@ _call_info: FORCE
$(TOPDIR)/tmp/opkg.conf: FORCE
@mkdir -p $(TOPDIR)/tmp
@mkdir -p $(TARGET_DIR)/tmp
- @echo 'dest root /' > $@
- @echo 'src packages file:$(PACKAGE_DIR)' >> $@
- @echo 'arch all 100' >> $@
-ifneq ($(CONFIG_TARGET_adm5120),y)
- @echo 'arch $(BOARD) 200' >> $@
-else
- @echo 'arch $(BOARD)_$(ARCH) 200' >> $@
-endif
- @echo 'option offline_root $(TARGET_DIR)' >> $@
+ @$(TOPDIR)/scripts/opkg-generate-config.sh $(TARGET_DIR)
BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(USER_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
# "-pkgname" in the package list means remove "pkgname" from the package list
BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))
+PACKAGES:=
_call_image:
echo 'Building images for $(BOARD)$(if $($(USER_PROFILE)_NAME), - $($(USER_PROFILE)_NAME))'