aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-11 00:18:12 +0000
committerMike Baker <mbm@openwrt.org>2006-05-11 00:18:12 +0000
commit8b7d9fc053b56827d196da7d2dced619a9d6504d (patch)
tree29711a0aebbf2387d85e7ae971b3dd253edebf6b /rules.mk
parent0ce063db66999ec583f94a2ecd07ea208730b769 (diff)
downloadmaster-187ad058-8b7d9fc053b56827d196da7d2dced619a9d6504d.tar.gz
master-187ad058-8b7d9fc053b56827d196da7d2dced619a9d6504d.tar.bz2
master-187ad058-8b7d9fc053b56827d196da7d2dced619a9d6504d.zip
partial cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3758 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk18
1 files changed, 16 insertions, 2 deletions
diff --git a/rules.mk b/rules.mk
index 417dae7de0..d94a818441 100644
--- a/rules.mk
+++ b/rules.mk
@@ -5,9 +5,23 @@ endif
SHELL=/bin/bash
export SHELL
-ifeq ($(V),)
-V=5
+ifdef V
+ ifeq ("$(origin V)", "command line")
+ KBUILD_VERBOSE = $(V)
+ endif
endif
+ifndef KBUILD_VERBOSE
+ KBUILD_VERBOSE = 0
+endif
+
+ifneq ($(KBUILD_VERBOSE),0)
+ quiet =
+ Q =
+else
+ quiet=quiet_
+ Q = @
+endif
+
CP=cp -fpR
MAKE1=make