aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-08 02:24:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-08 02:24:45 +0000
commitecd9b3f9d81965557d9f7e7e1bd6620b4f5f1907 (patch)
tree8c931276925601a0ab3b0e1683bc4b18382961fa /package
parent37a1dc4602c26f567926efe496410c95c90c5283 (diff)
downloadmaster-187ad058-ecd9b3f9d81965557d9f7e7e1bd6620b4f5f1907.tar.gz
master-187ad058-ecd9b3f9d81965557d9f7e7e1bd6620b4f5f1907.tar.bz2
master-187ad058-ecd9b3f9d81965557d9f7e7e1bd6620b4f5f1907.zip
install static libraries from uclibc to the rootfs staging dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17169 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 2c88458af4..6901829f29 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -247,6 +247,10 @@ define Package/libc/install
$(call Package/$(LIBC)/install,$1)
endef
+define Package/libc/install_lib
+ $(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+endef
+
define Package/libpthread/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(TOOLCHAIN_DIR)/lib/libpthread.so.* $(1)/lib/