aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-02-25 21:00:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-02-25 21:00:23 +0000
commitb70a65718fea832f987ab5f350ae070ed2b8b6b5 (patch)
tree070f8857af0f1acd7078fdd266ebe2b45ebde929 /package
parentd2d9abec243d773015e24fe6941732ff2df1cb1a (diff)
downloadmaster-187ad058-b70a65718fea832f987ab5f350ae070ed2b8b6b5.tar.gz
master-187ad058-b70a65718fea832f987ab5f350ae070ed2b8b6b5.tar.bz2
master-187ad058-b70a65718fea832f987ab5f350ae070ed2b8b6b5.zip
[package] firewall: allow ICMPv6 type 129 (echo reply) - this fixes basic ICMPv6 in case no connection tracking is used
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30727 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/firewall.config2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index b03fca8a03..1367cc38dd 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=46
+PKG_RELEASE:=47
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/firewall.config b/package/firewall/files/firewall.config
index 77832ffaca..6322922651 100644
--- a/package/firewall/files/firewall.config
+++ b/package/firewall/files/firewall.config
@@ -64,6 +64,7 @@ config rule
option src wan
option proto icmp
list icmp_type echo-request
+ list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded
@@ -82,6 +83,7 @@ config rule
option dest *
option proto icmp
list icmp_type echo-request
+ list icmp_type echo-reply
list icmp_type destination-unreachable
list icmp_type packet-too-big
list icmp_type time-exceeded