aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-03-10 15:41:04 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-03-10 15:41:04 +0000
commit97f990f6389cf010f45784be1d1134a8b67ceacd (patch)
tree49d9e8625f3bb15e5e7422e23bc27f4d1ad4cb2b /package
parent09779f376b5c03baa9c19bf5d885adb3d607022c (diff)
downloadmaster-187ad058-97f990f6389cf010f45784be1d1134a8b67ceacd.tar.gz
master-187ad058-97f990f6389cf010f45784be1d1134a8b67ceacd.tar.bz2
master-187ad058-97f990f6389cf010f45784be1d1134a8b67ceacd.zip
[package] kernel: further fixes to kmod-gre packaging
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26012 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netsupport.mk14
1 files changed, 8 insertions, 6 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 25e2ac42c2..0116283045 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -370,12 +370,14 @@ $(eval $(call KernelPackage,ip6-tunnel))
define KernelPackage/gre
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=GRE support
- KCONFIG:=CONFIG_NET_IPGRE \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
- FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
- AUTOLOAD:=$(call AutoLoad,39, \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),gre) ip_gre)
+ KCONFIG:=CONFIG_NET_IPGRE CONFIG_NET_IPGRE_DEMUX
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),1)
+ FILES:=$(LINUX_DIR)/net/ipv4/ip_gre.ko $(LINUX_DIR)/net/ipv4/gre.ko
+ AUTOLOAD:=$(call AutoLoad,39,gre ip_gre)
+ else
+ FILES:=$(LINUX_DIR)/net/ipv4/ip_gre.ko
+ AUTOLOAD:=$(call AutoLoad,39,ip_gre)
+ endif
endef
define KernelPackage/gre/description