aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-05-28 18:23:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-05-28 18:23:49 +0000
commit8768d25dbdbfd8d96c48d222567475aa48283272 (patch)
treeb7a88dcd194c11a8d3373536e4c404df5cd7b419 /package
parent5ba9b4642ec0857358d8fddca06039e2fd19fac2 (diff)
downloadmaster-187ad058-8768d25dbdbfd8d96c48d222567475aa48283272.tar.gz
master-187ad058-8768d25dbdbfd8d96c48d222567475aa48283272.tar.bz2
master-187ad058-8768d25dbdbfd8d96c48d222567475aa48283272.zip
fix kmod-usb-hid package build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7378 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/usb.mk8
1 files changed, 3 insertions, 5 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index ad037d6196..e36a52e463 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -333,17 +333,15 @@ endef
$(eval $(call KernelPackage,usb-net-asix))
define KernelPackage/usb-hid
- $(call usbdep,@LINUX_2_6)
+ $(call usbdep,@LINUX_2_6 evdev)
TITLE:=Support for USB Human Input Devices
DESCRIPTION:=Kernel support for USB HID devices such as keyboards and mice
KCONFIG:=$(CONFIG_USB_HID)
- AUTOLOAD:=$(call AutoLoad,70,usbhid evdev)
+ AUTOLOAD:=$(call AutoLoad,70,usbhid)
endef
define KernelPackage/usb-hid/2.6
- FILES:= \
- $(LINUX_DIR)/drivers/usb/input/usbhid.ko \
- $(LINUX_DIR)/drivers/input/evdev.ko
+ FILES:=$(LINUX_DIR)/drivers/usb/input/usbhid.ko
endef
$(eval $(call KernelPackage,usb-hid))