aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-28 13:45:06 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-28 13:45:06 +0000
commit7558535a9e02a19359425a029fb538f4ef64d651 (patch)
tree21491121b74294eb521ae7c8bcac455eaaeb451a /package
parent120fdaa996e1a09570b7dfd674368b6726522b3b (diff)
downloadmaster-187ad058-7558535a9e02a19359425a029fb538f4ef64d651.tar.gz
master-187ad058-7558535a9e02a19359425a029fb538f4ef64d651.tar.bz2
master-187ad058-7558535a9e02a19359425a029fb538f4ef64d651.zip
linux: add upstream patch to allow building dwc2 as module on 3.18
Also add the required config symbols to usb.mk Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44181 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 3db70f8951..2499af1007 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -438,6 +438,8 @@ define KernelPackage/usb-dwc2
DEPENDS:=@!LINUX_3_8 @!LINUX_3_10
KCONFIG:= \
CONFIG_USB_DWC2 \
+ CONFIG_USB_DWC2_PCI \
+ CONFIG_USB_DWC2_PLATFORM \
CONFIG_USB_DWC2_DEBUG=n \
CONFIG_USB_DWC2_VERBOSE=n \
CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n