aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-13 03:02:28 +0000
commit6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2 (patch)
treefc284dc684b04e5289b1046ec0c213b085faf214 /package
parentd057b4aae39c3b12d2ab141df88bc0f073d4c4b4 (diff)
downloadmaster-187ad058-6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2.tar.gz
master-187ad058-6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2.tar.bz2
master-187ad058-6402b8402fb7ae4ce2874ca4b63c730b01f4b4a2.zip
Rename 'atheros' target to 'ath25'
Rename 'atheros' target to more precise 'ath25'. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44736 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile6
-rw-r--r--package/kernel/wrt55agv2-spidevs/Makefile2
2 files changed, 4 insertions, 4 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index e487fe7144..6623c5ad39 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -534,7 +534,7 @@ endef
define KernelPackage/ath
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros common driver part
- DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ar71xx||TARGET_atheros +kmod-mac80211
+ DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ar71xx||TARGET_ath25 +kmod-mac80211
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath.ko
MENU:=1
endef
@@ -547,7 +547,7 @@ define KernelPackage/ath5k
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 5xxx wireless cards support
URL:=http://linuxwireless.org/en/users/Drivers/ath5k
- DEPENDS+= @PCI_SUPPORT||@TARGET_atheros +kmod-ath
+ DEPENDS+= @PCI_SUPPORT||@TARGET_ath25 +kmod-ath
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath5k/ath5k.ko
AUTOLOAD:=$(call AutoProbe,ath5k)
endef
@@ -1556,7 +1556,7 @@ config-$(call config_package,ath9k-htc) += ATH9K_HTC
config-$(call config_package,ath10k) += ATH10K ATH10K_PCI
config-$(call config_package,ath5k) += ATH5K
-ifdef CONFIG_TARGET_atheros
+ifdef CONFIG_TARGET_ath25
config-y += ATH5K_AHB
else
config-y += ATH5K_PCI
diff --git a/package/kernel/wrt55agv2-spidevs/Makefile b/package/kernel/wrt55agv2-spidevs/Makefile
index bfd24c2f8d..a63180b8f9 100644
--- a/package/kernel/wrt55agv2-spidevs/Makefile
+++ b/package/kernel/wrt55agv2-spidevs/Makefile
@@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/wrt55agv2-spidevs
SUBMENU:=Other modules
TITLE:=WRT55AG v2 SPI devices support
- DEPENDS:=@TARGET_atheros +kmod-spi-gpio-old +kmod-spi-ks8995
+ DEPENDS:=@TARGET_ath25 +kmod-spi-gpio-old +kmod-spi-ks8995
FILES:=$(PKG_BUILD_DIR)/wrt55agv2_spidevs.ko
endef