aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-14 12:12:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-14 12:12:25 +0000
commit6175f4168bc96472d1e0e4c42ea69789a8580564 (patch)
tree8f20c57f61576252e6a965d74fc7ed82b1740277 /package
parent939914d5e72990671ed74be6276dfdb46b0d3092 (diff)
downloadmaster-187ad058-6175f4168bc96472d1e0e4c42ea69789a8580564.tar.gz
master-187ad058-6175f4168bc96472d1e0e4c42ea69789a8580564.tar.bz2
master-187ad058-6175f4168bc96472d1e0e4c42ea69789a8580564.zip
ath9k: always select relay support, not just when debugfs is enabled - fixes an unresolved symbol error
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44754 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 6623c5ad39..a18ccdc02f 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -92,7 +92,6 @@ define KernelPackage/mac80211/config
config PACKAGE_MAC80211_DEBUGFS
bool "Export mac80211 internals in DebugFS"
select KERNEL_DEBUG_FS
- select KERNEL_RELAY if PACKAGE_kmod-ath9k-common
default y
help
Select this to see extensive information about
@@ -561,7 +560,7 @@ define KernelPackage/ath9k-common
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 802.11n wireless devices (common code for ath9k and ath9k_htc)
URL:=http://linuxwireless.org/en/users/Drivers/ath9k
- DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ar71xx +kmod-ath +@DRIVER_11N_SUPPORT
+ DEPENDS+= @PCI_SUPPORT||USB_SUPPORT||TARGET_ar71xx +kmod-ath +@DRIVER_11N_SUPPORT +@KERNEL_RELAY
FILES:= \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_common.ko \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath9k/ath9k_hw.ko