aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:40:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:40:52 +0000
commit4a5a71ea72dad7cce49926247991469742a7d279 (patch)
tree36671761ee1b18ea6c48f7f14678c8b555aca07b /package
parentcfaf6e9e3da0613cb2f5fe4eabfb810504677d94 (diff)
downloadmaster-187ad058-4a5a71ea72dad7cce49926247991469742a7d279.tar.gz
master-187ad058-4a5a71ea72dad7cce49926247991469742a7d279.tar.bz2
master-187ad058-4a5a71ea72dad7cce49926247991469742a7d279.zip
samba36: remove host build paths
- fix iconv detection because it adds host paths - disable python detection (host python-config is found) iconv issue is reported by buildbot config.log + replicated locally see config.log in logs.tar.gz python issue observed locally on Arch Linux Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45953 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/services/samba36/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index b39f4840e3..d8b930c989 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=samba
PKG_VERSION:=3.6.25
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
http://ftp.samba.org/pub/samba/stable
@@ -35,7 +35,7 @@ define Package/samba36-server
CATEGORY:=Network
TITLE:=Samba 3.6 SMB/CIFS server
URL:=http://www.samba.org/
- DEPENDS:=+USE_GLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
endef
define Package/samba36-client
@@ -83,7 +83,9 @@ CONFIGURE_VARS += \
samba_cv_have_setreuid=yes \
samba_cv_have_setresuid=yes \
ac_cv_header_zlib_h=no \
- samba_cv_zlib_1_2_3=no
+ samba_cv_zlib_1_2_3=no \
+ ac_cv_path_PYTHON="" \
+ ac_cv_path_PYTHON_CONFIG=""
CONFIGURE_ARGS += \
--exec-prefix=/usr \
@@ -95,6 +97,7 @@ CONFIGURE_ARGS += \
--disable-static \
--disable-swat \
--disable-shared-libs \
+ --with-libiconv="$(ICONV_PREFIX)" \
--with-codepagedir=/etc/samba \
--with-configdir=/etc/samba \
--with-included-iniparser \