aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:25 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:25 +0000
commit449b44a5744bdef79dc6eba62b5628a99be5517c (patch)
tree99f29faf17c6a9e3a171eea7f4f663247a0b0db6 /package
parentab871f9a825e054fce91bb24ab8a57a691df0afb (diff)
downloadmaster-187ad058-449b44a5744bdef79dc6eba62b5628a99be5517c.tar.gz
master-187ad058-449b44a5744bdef79dc6eba62b5628a99be5517c.tar.bz2
master-187ad058-449b44a5744bdef79dc6eba62b5628a99be5517c.zip
package/kernel: package NAND support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30773 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk22
1 files changed, 21 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 9ab6700b7f..5a4cce8ce3 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -629,7 +629,7 @@ define KernelPackage/cs5535-mfd
KCONFIG:=CONFIG_MFD_CS5535
FILES:= \
$(LINUX_DIR)/drivers/mfd/mfd-core.ko \
- $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko
+ $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko
AUTOLOAD:=$(call AutoLoad,44,mfd-core cs5535-mfd)
endef
@@ -818,3 +818,23 @@ define KernelPackage/mtdtests/description
endef
$(eval $(call KernelPackage,mtdtests))
+
+
+define KernelPackage/nand
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=NAND flash support
+ KCONFIG:=CONFIG_MTD_NAND \
+ CONFIG_MTD_NAND_IDS \
+ CONFIG_MTD_NAND_ECC
+ FILES:= \
+ $(LINUX_DIR)/drivers/mtd/nand/nand_ids.ko \
+ $(LINUX_DIR)/drivers/mtd/nand/nand_ecc.ko \
+ $(LINUX_DIR)/drivers/mtd/nand/nand.ko
+ AUTOLOAD:=$(call AutoLoad,20,nand_ids nand_ecc nand)
+endef
+
+define KernelPackage/nand/description
+ Kernel module for NAND support.
+endef
+
+$(eval $(call KernelPackage,nand))