aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-05-23 09:35:27 +0000
committerLuka Perkov <luka@openwrt.org>2014-05-23 09:35:27 +0000
commit427f0f4a87cf37baa2c7e707247577bb82034401 (patch)
tree4eee7f44c0391356305be227d3170fbf9e7edcf5 /package
parentf0cf7240b0ea36af381a30ff517403c6e6b2a259 (diff)
downloadmaster-187ad058-427f0f4a87cf37baa2c7e707247577bb82034401.tar.gz
master-187ad058-427f0f4a87cf37baa2c7e707247577bb82034401.tar.bz2
master-187ad058-427f0f4a87cf37baa2c7e707247577bb82034401.zip
kernel: other.mk: add pps-gpio support
The pps-gpio kernel module supports Pulse-Per-Second provided by a GPIO. Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40831 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 00c73fc920..8f68bd8251 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -775,6 +775,24 @@ endef
$(eval $(call KernelPackage,pps))
+define KernelPackage/pps-gpio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PPS client using GPIO
+ DEPENDS:=+kmod-pps
+ KCONFIG:=CONFIG_PPS_CLIENT_GPIO
+ FILES:=$(LINUX_DIR)/drivers/pps/clients/pps-gpio.ko
+ AUTOLOAD:=$(call AutoLoad,18,pps-gpio,1)
+endef
+
+define KernelPacakge/pps-gpio/description
+ Support for a PPS source using GPIO. To be useful you must
+ also register a platform device specifying the GPIO pin and
+ other options, usually in your board setup.
+endef
+
+$(eval $(call KernelPackage,pps-gpio))
+
+
define KernelPackage/ptp
SUBMENU:=$(OTHER_MENU)
TITLE:=PTP clock support