aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2012-04-28 22:24:12 +0000
committerMirko Vogt <mirko@openwrt.org>2012-04-28 22:24:12 +0000
commit3b19d53edd512d871709f3a3c39b7c7c9d0f8f03 (patch)
tree32178f4f4735188a13b27010dfea79fe2f1b07f4 /package
parentd7efd1199d12100470dcf4e830c806bf411d0945 (diff)
downloadmaster-187ad058-3b19d53edd512d871709f3a3c39b7c7c9d0f8f03.tar.gz
master-187ad058-3b19d53edd512d871709f3a3c39b7c7c9d0f8f03.tar.bz2
master-187ad058-3b19d53edd512d871709f3a3c39b7c7c9d0f8f03.zip
[toolchain/glibc*] purge support for glibc - use eglibc instead!
for reference: http://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg13425.html git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31503 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile8
-rw-r--r--package/base-files/eglibc-files/etc/nsswitch.conf (renamed from package/base-files/glibc-files/etc/nsswitch.conf)0
2 files changed, 2 insertions, 6 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index a230b1bf06..b22e6b308b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -516,8 +516,8 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
use_libnsl=$(if $(CONFIG_USE_GLIBC)$(CONFIG_EGLIBC_OPTION_EGLIBC_NIS),libnsl)
use_nsswitch=$(if $(CONFIG_USE_GLIBC)$(CONFIG_EGLIBC_OPTION_EGLIBC_NSSWITCH),libnss_dns libnss_files)
- define Package/glibc/install
- $(CP) ./glibc-files/* $(1)/
+ define Package/eglibc/install
+ $(CP) ./eglibc-files/* $(1)/
rm -f $(1)/etc/localtime
ln -sf /tmp/localtime $(1)/etc/localtime
$(INSTALL_DIR) $(1)/lib
@@ -534,10 +534,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
done
endef
- define Package/eglibc/install
- $(call Package/glibc/install,$1)
- endef
-
define Package/uClibc/install
$(INSTALL_DIR) $(1)/lib
$(CP) \
diff --git a/package/base-files/glibc-files/etc/nsswitch.conf b/package/base-files/eglibc-files/etc/nsswitch.conf
index 981c425da6..981c425da6 100644
--- a/package/base-files/glibc-files/etc/nsswitch.conf
+++ b/package/base-files/eglibc-files/etc/nsswitch.conf