aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-06 19:02:27 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-06 19:02:27 +0000
commit31aac3c47e6ef76b97281a75c29fe46ddfa39d32 (patch)
tree6e6d059e30804801975ebc3eabd90d4958034d4d /package
parent5842cbd731e82910fde02590ccd50ce5a8eb054b (diff)
downloadmaster-187ad058-31aac3c47e6ef76b97281a75c29fe46ddfa39d32.tar.gz
master-187ad058-31aac3c47e6ef76b97281a75c29fe46ddfa39d32.tar.bz2
master-187ad058-31aac3c47e6ef76b97281a75c29fe46ddfa39d32.zip
ltq-tapi/vmmc were build on none lantiq targets due to bad builddepends of pjsip
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27498 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/ltq-tapi/Makefile6
-rw-r--r--package/ltq-vmmc/Makefile10
-rw-r--r--package/pjsip/Makefile2
3 files changed, 7 insertions, 11 deletions
diff --git a/package/ltq-tapi/Makefile b/package/ltq-tapi/Makefile
index 64d7defaf3..ecaac2eeb4 100644
--- a/package/ltq-tapi/Makefile
+++ b/package/ltq-tapi/Makefile
@@ -60,12 +60,10 @@ define Build/Configure
$(call Build/Configure/Default)
endef
-ifdef CONFIG_TARGET_lantiq
- define Build/InstallDev
+define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/drv_tapi
$(CP) --dereference $(PKG_BUILD_DIR)/include/* $(1)/usr/include/drv_tapi
(cd $(1)/usr/include/drv_tapi && ln -s . include && ln -s ../ifxos/ifx_types.h .)
- endef
-endif
+endef
$(eval $(call KernelPackage,ltq-tapi))
diff --git a/package/ltq-vmmc/Makefile b/package/ltq-vmmc/Makefile
index 8ca4e2398f..51c33f57ea 100644
--- a/package/ltq-vmmc/Makefile
+++ b/package/ltq-vmmc/Makefile
@@ -143,20 +143,18 @@ define Build/Configure
$(call Build/Configure/Default)
endef
-ifdef CONFIG_TARGET_lantiq
- define Build/InstallDev
+define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
mkdir -p $(1)/usr/include/drv_vmmc
$(CP) -v --dereference $(PKG_BUILD_DIR)/include/* $(1)/usr/include/drv_vmmc
(cd $(1)/usr/include/drv_vmmc && ln -snf . include)
- endef
+endef
- define KernelPackage/ltq-vmmc/install
+define KernelPackage/ltq-vmmc/install
$(INSTALL_DIR) $(1)/etc/init.d $(1)/$(FW_DIR)
$(INSTALL_BIN) ./files/vmmc.init $(1)/etc/init.d/vmmc
$(CP) $(PKG_BUILD_DIR)/firmware/$(FW_SOURCE) $(1)/$(FW_DIR)/$(FW_TARGET)
$(CP) $(PKG_BUILD_DIR)/coef/$(COEF_SRC) $(1)/$(FW_DIR)/$(COEF_TARGET)
- endef
-endif
+endef
$(eval $(call KernelPackage,ltq-vmmc))
diff --git a/package/pjsip/Makefile b/package/pjsip/Makefile
index 4f385723ab..42db149baf 100644
--- a/package/pjsip/Makefile
+++ b/package/pjsip/Makefile
@@ -66,7 +66,7 @@ EXTRA_CFLAGS:=-I$(STAGING_DIR)/usr/include/drv_tapi -I$(STAGING_DIR)/usr/include
endif
Package/pjsip-oss=$(call Package/pjsip-template,oss,)
-Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +kmod-ltq-tapi +kmod-ltq-vmmc)
+Package/pjsip-ltq-tapi=$(call Package/pjsip-template,ltq-tapi,@TARGET_lantiq +TARGET_lantiq:kmod-ltq-tapi +TARGET_lantiq:kmod-ltq-vmmc)
define Build/Prepare
$(PKG_UNPACK)