aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-14 16:14:27 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-14 16:14:27 +0000
commit309c36fac06ff52bc076c0394ac293f74a138d79 (patch)
treed6c8094df0174b24eb28240901da749be397aa04 /package
parent1e6ac8639eda0e201865f166e2abc62cfd26f43c (diff)
downloadmaster-187ad058-309c36fac06ff52bc076c0394ac293f74a138d79.tar.gz
master-187ad058-309c36fac06ff52bc076c0394ac293f74a138d79.tar.bz2
master-187ad058-309c36fac06ff52bc076c0394ac293f74a138d79.zip
[package] base-files: dispatch ifdown events for proto=none interfaces and fix a race condition between revert state and hotplug handlers
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17582 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/ifdown4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 4661a5a575..d87253b4dd 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=29
+PKG_RELEASE:=30
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/sbin/ifdown b/package/base-files/files/sbin/ifdown
index 883f8ec428..8de414d8b6 100755
--- a/package/base-files/files/sbin/ifdown
+++ b/package/base-files/files/sbin/ifdown
@@ -22,8 +22,8 @@ config_get proto "$cfg" proto
[ -z "$proto" ] && { echo "interface not found."; exit; }
config_get iface "$cfg" device
-[ "static" = "$proto" ] && {
- env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO=static /sbin/hotplug-call "iface" &
+[ "static" = "$proto" -o "none" = "$proto" ] && {
+ env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO="$proto" /sbin/hotplug-call "iface"
}
# call interface stop handler