aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-12 15:31:00 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-12 15:31:00 +0000
commit306fd791257af34804c8f7b3322bef61a517d56c (patch)
tree6ff7c7665b1f5541ecc0c6389bcc0618e914eeb6 /package
parentdee3ed024e8a9962f642d9f899cd7ea0426a4847 (diff)
downloadmaster-187ad058-306fd791257af34804c8f7b3322bef61a517d56c.tar.gz
master-187ad058-306fd791257af34804c8f7b3322bef61a517d56c.tar.bz2
master-187ad058-306fd791257af34804c8f7b3322bef61a517d56c.zip
Fix compilation of crypto modules.
This fixes #7920 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23028 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/crypto.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 1ec540be1b..3be3afdcaa 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -22,9 +22,9 @@ SHA256_SUFFIX:=$(CRYPTO_GENERIC)
SHA512_SUFFIX:=$(CRYPTO_GENERIC)
CRYPTO_MODULES = \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),ALGAPI2,ALGAPI)=crypto_algapi \
+ $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),ALGAPI2,ALGAPI)=crypto_algapi \
AEAD2=aead \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
+ $(if $(filter 1,$(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)=pcompress \
BLKCIPHER2=crypto_blkcipher \
HASH2=crypto_hash \
MANAGER2=cryptomgr \