aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-23 09:36:03 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-23 09:36:03 +0000
commit22514e847630a0a5d5ffebcdc0e93b6fef113c37 (patch)
treecae800cf54126164c21b223b861a19bf774e8daa /package
parentaa0e6f7f134451af40dc7953bdbb973f2b11b6ac (diff)
downloadmaster-187ad058-22514e847630a0a5d5ffebcdc0e93b6fef113c37.tar.gz
master-187ad058-22514e847630a0a5d5ffebcdc0e93b6fef113c37.tar.bz2
master-187ad058-22514e847630a0a5d5ffebcdc0e93b6fef113c37.zip
mac80211: disable ipw2x00 for big endian targets
The ipw2x00 drivers assume that the system they are running is little endian, and access everything in native byte order. When run on a big endian system, everything breaks apart. Since fixing this is non trivial on a first glance, disable them for big endian targets. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46708 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 6afef107cb..04dfd3b4ea 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -719,7 +719,7 @@ endef
define KernelPackage/net-libipw
$(call KernelPackage/mac80211/Default)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT @!BIG_ENDIAN
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ipw2x00/libipw.ko
AUTOLOAD:=$(call AutoProbe,libipw)
endef