aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2011-03-07 16:14:10 +0000
committerMichael Büsch <mb@bu3sch.de>2011-03-07 16:14:10 +0000
commit1f9e5ba1930dcda96d4a7a5462e53379e284a5a3 (patch)
treeeaf13e5a2e9dea84ae397910d5743737d26a78b0 /package
parent8743391afe161d299d8475363852d82cee6388b0 (diff)
downloadmaster-187ad058-1f9e5ba1930dcda96d4a7a5462e53379e284a5a3.tar.gz
master-187ad058-1f9e5ba1930dcda96d4a7a5462e53379e284a5a3.tar.bz2
master-187ad058-1f9e5ba1930dcda96d4a7a5462e53379e284a5a3.zip
omap24xx: Add config option for n810 bluetooth driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25934 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 0ecc7b3786..aba1c6b7d1 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -55,6 +55,22 @@ endef
$(eval $(call KernelPackage,bluetooth))
+define KernelPackage/bluetooth-hci-h4p
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=HCI driver with H4 Nokia extensions
+ DEPENDS:=@TARGET_omap24xx +kmod-bluetooth
+ KCONFIG:=CONFIG_BT_HCIH4P
+ FILES:=$(LINUX_DIR)/drivers/bluetooth/hci_h4p/hci_h4p.ko
+ AUTOLOAD:=$(call AutoLoad,91,hci_h4p)
+endef
+
+define KernelPackage/bluetooth-hci-h4p/description
+ HCI driver with H4 Nokia extensions
+endef
+
+$(eval $(call KernelPackage,bluetooth-hci-h4p))
+
+
define KernelPackage/cpu-msr
SUBMENU:=$(OTHER_MENU)
TITLE:=x86 CPU MSR support