aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-28 19:19:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-28 19:19:57 +0000
commit07a6a43d1d7e4afe9badcb8b1173baae64856ac2 (patch)
treef7c4257165a767151c5c5ddd4f705405580eff22 /package
parentf91b6a228cfff357b80443063005fc18a286c690 (diff)
downloadmaster-187ad058-07a6a43d1d7e4afe9badcb8b1173baae64856ac2.tar.gz
master-187ad058-07a6a43d1d7e4afe9badcb8b1173baae64856ac2.tar.bz2
master-187ad058-07a6a43d1d7e4afe9badcb8b1173baae64856ac2.zip
modules: Add support for Realtek r8712 and RTL8192SU.
This patch adds support for Realtek r8712 and RTL8188SU/RTL8191SU/RTL8192SU family of fullmac usb wireless cards. The r8712u staging driver only supports WEXT but works with no problems in OpenWRT. Signed off by: José Vázquez Fernández <ppvazquezfer@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44184 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/wireless.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/wireless.mk b/package/kernel/linux/modules/wireless.mk
index 97b4366978..f02e8b9b4e 100644
--- a/package/kernel/linux/modules/wireless.mk
+++ b/package/kernel/linux/modules/wireless.mk
@@ -126,3 +126,35 @@ endef
$(eval $(call KernelPackage,net-rtl8188eu))
+define KernelPackage/net-rtl8192su
+ SUBMENU:=$(WIRELESS_MENU)
+ TITLE:=RTL8192SU support (staging)
+ DEPENDS:=@USB_SUPPORT +@DRIVER_WEXT_SUPPORT +kmod-usb-core
+ KCONFIG:=\
+ CONFIG_STAGING=y \
+ CONFIG_R8712U
+ FILES:=$(LINUX_DIR)/drivers/staging/rtl8712/r8712u.ko
+ AUTOLOAD:=$(call AutoProbe,r8712u)
+endef
+
+define KernelPackage/net-rtl8192su/description
+ Kernel modules for RealTek RTL8712 and RTL81XXSU fullmac support.
+endef
+
+# R8712 FullMAC firmware
+R8712_FW:=rtl8712u.bin
+
+define Download/net-rtl8192su
+ FILE:=$(R8712_FW)
+
+ URL:=http://mirrors.arizona.edu/raspbmc/downloads/bin/lib/wifi/rtlwifi/
+ MD5SUM:=8e6396b5844a3e279ae8679555dec3f0
+endef
+
+define KernelPackage/net-rtl8192su/install
+ $(INSTALL_DIR) $(1)/lib/firmware/rtlwifi
+ $(INSTALL_DATA) $(DL_DIR)/$(R8712_FW) $(1)/lib/firmware/rtlwifi/
+endef
+
+$(eval $(call Download,net-rtl8192su))
+$(eval $(call KernelPackage,net-rtl8192su))