aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/px5g/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-21 15:55:23 +0000
commitd0448ca8acaf1674057034724561344e1d28c17e (patch)
tree90ed8df156dbfda6100ace3391cc2439acb8b83f /package/utils/px5g/Makefile
parent55a9bf9653428218ca65420d10e3f2a67cac74fd (diff)
downloadmaster-187ad058-d0448ca8acaf1674057034724561344e1d28c17e.tar.gz
master-187ad058-d0448ca8acaf1674057034724561344e1d28c17e.tar.bz2
master-187ad058-d0448ca8acaf1674057034724561344e1d28c17e.zip
px5g: rename the old package to px5g-standalone, add a new one that links against polarssl
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40000 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/utils/px5g/Makefile')
-rw-r--r--package/utils/px5g/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/utils/px5g/Makefile b/package/utils/px5g/Makefile
index ad4ec40580..9c0caa7b8d 100644
--- a/package/utils/px5g/Makefile
+++ b/package/utils/px5g/Makefile
@@ -10,15 +10,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=px5g
PKG_RELEASE:=1
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)
+PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
define Package/px5g
SECTION:=utils
CATEGORY:=Utilities
- TITLE:=Standalone X.509 certificate generator
+ TITLE:=X.509 certificate generator (using PolarSSL)
MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+ DEPENDS:=+libpolarssl
endef
define Package/px5g/description
@@ -29,7 +31,10 @@ endef
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g.c -lpolarssl
endef
define Package/px5g/install