aboutsummaryrefslogtreecommitdiffstats
path: root/package/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-09-18 22:30:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-09-18 22:30:20 +0000
commit65866b3bba7edb9612f147f390ad5d0bce767df4 (patch)
tree5b80fc776abd11f37813ef9ce3a3ae95839d45a4 /package/uhttpd
parente327db6d62323855680731cec8275d26df90ce7e (diff)
downloadmaster-187ad058-65866b3bba7edb9612f147f390ad5d0bce767df4.tar.gz
master-187ad058-65866b3bba7edb9612f147f390ad5d0bce767df4.tar.bz2
master-187ad058-65866b3bba7edb9612f147f390ad5d0bce767df4.zip
[package] uhttpd: fix possible CGI header line parsing beyound the empty line, thanks Linus Luessing for spotting it
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28254 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uhttpd')
-rw-r--r--package/uhttpd/Makefile2
-rw-r--r--package/uhttpd/src/uhttpd-cgi.c8
2 files changed, 5 insertions, 5 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 5fa12fc8bc..4f29284883 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=26
+PKG_RELEASE:=27
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/uhttpd/src/uhttpd-cgi.c b/package/uhttpd/src/uhttpd-cgi.c
index ed688514c4..2f94fe26f5 100644
--- a/package/uhttpd/src/uhttpd-cgi.c
+++ b/package/uhttpd/src/uhttpd-cgi.c
@@ -1,7 +1,7 @@
/*
* uhttpd - Tiny single-threaded httpd - CGI handler
*
- * Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+ * Copyright (C) 2010-2011 Jo-Philipp Wich <xm@subsignal.org>
*
* Licensed under the Apache License, Version 2.0 (the "License");
* you may not use this file except in compliance with the License.
@@ -42,7 +42,7 @@ static struct http_response * uh_cgi_header_parse(char *buf, int len, int *off)
bufptr = &buf[0];
- for( pos = 0; pos < len; pos++ )
+ for( pos = 0; pos < off; pos++ )
{
if( !hdrname && (buf[pos] == ':') )
{
@@ -60,11 +60,11 @@ static struct http_response * uh_cgi_header_parse(char *buf, int len, int *off)
else if( (buf[pos] == '\r') || (buf[pos] == '\n') )
{
- buf[pos++] = 0;
-
if( ! hdrname )
break;
+ buf[pos++] = 0;
+
if( (pos < len) && (buf[pos] == '\n') )
pos++;