aboutsummaryrefslogtreecommitdiffstats
path: root/package/uhttpd/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-05 03:19:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-05 03:19:07 +0000
commit88dc98a3420ffdbd606a32718da739b008ebd01d (patch)
tree34be5f9820379f7b7a9edaad8fcba5e461b10663 /package/uhttpd/Makefile
parent2149ed4fe1cd50eaa8e3148908ff1beca7ba6e22 (diff)
downloadmaster-187ad058-88dc98a3420ffdbd606a32718da739b008ebd01d.tar.gz
master-187ad058-88dc98a3420ffdbd606a32718da739b008ebd01d.tar.bz2
master-187ad058-88dc98a3420ffdbd606a32718da739b008ebd01d.zip
[package] uhttpd: rework CyaSSL and OpenSSL integration; move protected recv() and send() operations below the ssl layer - fixes hangs when accessing via https
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28761 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uhttpd/Makefile')
-rw-r--r--package/uhttpd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 4f29284883..daf7333cd6 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -65,14 +65,16 @@ endef
UHTTPD_TLS:=
TLS_CFLAGS:=
+TLS_LDFLAGS:=
ifneq ($(CONFIG_PACKAGE_uhttpd-mod-tls_cyassl),)
UHTTPD_TLS:=cyassl
- TLS_CFLAGS:=-I$(STAGING_DIR)/usr/include/cyassl
+ TLS_CFLAGS:=-I$(STAGING_DIR)/usr/include/cyassl -DTLS_IS_CYASSL
endif
ifneq ($(CONFIG_PACKAGE_uhttpd-mod-tls_openssl),)
UHTTPD_TLS:=openssl
+ TLS_CFLAGS:=-DTLS_IS_OPENSSL
endif