aboutsummaryrefslogtreecommitdiffstats
path: root/package/uci
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-04-04 21:48:43 +0000
committerAndy Boyett <agb@openwrt.org>2008-04-04 21:48:43 +0000
commit21ee2eacd2898c8cd05b34d090a30ab6c13036ba (patch)
treeab98d6a5d44a5327e5eb644186ba7929f595bb38 /package/uci
parent9693c705020ebf774406c30a17cd3a5ddf56270c (diff)
downloadmaster-187ad058-21ee2eacd2898c8cd05b34d090a30ab6c13036ba.tar.gz
master-187ad058-21ee2eacd2898c8cd05b34d090a30ab6c13036ba.tar.bz2
master-187ad058-21ee2eacd2898c8cd05b34d090a30ab6c13036ba.zip
Install libuci and headers in staging_dir
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10732 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uci')
-rw-r--r--package/uci/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/uci/Makefile b/package/uci/Makefile
index 54d01c1589..41430f7e14 100644
--- a/package/uci/Makefile
+++ b/package/uci/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -73,6 +73,13 @@ define Package/uci-sh/install
$(CP) ./files/uci-sh/* $(1)/
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+endef
+
$(eval $(call BuildPackage,uci))
$(eval $(call BuildPackage,libuci))
$(eval $(call BuildPackage,uci-sh))